summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-15 19:48:10 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-15 19:48:10 +0000
commit9d8715562c846a78b9679d405d136e05a2fa330f (patch)
treee650519838a9fd2d9d253d9ab7922fe41db8aa7e /system
parent35084cdac05c798cdaa923e2fdeb48c97051918b (diff)
downloadpackages-9d8715562c846a78b9679d405d136e05a2fa330f.tar.gz
packages-9d8715562c846a78b9679d405d136e05a2fa330f.tar.bz2
packages-9d8715562c846a78b9679d405d136e05a2fa330f.tar.xz
packages-9d8715562c846a78b9679d405d136e05a2fa330f.zip
system/gettext-tiny: Fix --keyword handling
Upstream: https://github.com/sabotage-linux/gettext-tiny/pull/53
Diffstat (limited to 'system')
-rw-r--r--system/gettext-tiny/APKBUILD4
-rw-r--r--system/gettext-tiny/keyword.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/system/gettext-tiny/APKBUILD b/system/gettext-tiny/APKBUILD
index 702b85130..ce62d5c99 100644
--- a/system/gettext-tiny/APKBUILD
+++ b/system/gettext-tiny/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gettext-tiny
pkgver=0.3.1_git20191130
-pkgrel=1
+pkgrel=2
pkgdesc="An internationalisation and localisation system"
url="https://github.com/sabotage-linux/gettext-tiny"
arch="all"
@@ -12,6 +12,7 @@ depends=""
makedepends=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
+ keyword.patch
line-length.patch
respect-cflags.patch
stop-doing-macro-crap.patch
@@ -26,6 +27,7 @@ package() {
}
sha512sums="a318135626a0403a30a81fa475f7e1878b8af5a87053b0e00876c73b591508f3cf1e66d01f8d6a45013d1dc36a4da9f21fbf2b5050676826cb618b5b659aaaf7 gettext-tiny-0.3.1_git20191130.tar.xz
+8efbf9c11429ab26f3c15e00c34258200598833b8f846a23e4c8d95023c2184d9dcf9cbb48d58eec1604442691af76e6f8e904ad7348016c393257aa30eae7cd keyword.patch
0a26a8481bffe2ce8c73f7f500963aea9db8379fb87849142d8efabf1656604b22f6ad345483256f14c388466f2f44e5924b9f65d88f26867a753a96d1529270 line-length.patch
b4e7db4e415f6bc31f2214f2044506ad18ea0bd3cae4200d93bbd34aa493c7478a7f953d0a7e08f29f0fd5a5d7b7cbfa2bcfd5692c37e423706a1c193239bf1d respect-cflags.patch
cd4cfc8cc6ea998f1e33ef666e3b9c3de3f3253994bccc942b177773c94f785e3892cb7d5f34bec1102dc7558236c07c5eac90e15d755e12ee06836336373526 stop-doing-macro-crap.patch"
diff --git a/system/gettext-tiny/keyword.patch b/system/gettext-tiny/keyword.patch
new file mode 100644
index 000000000..417f8c80a
--- /dev/null
+++ b/system/gettext-tiny/keyword.patch
@@ -0,0 +1,13 @@
+diff --git a/src/msgfmt.c b/src/msgfmt.c
+index 1120ff6..f75ab8b 100644
+--- a/src/msgfmt.c
++++ b/src/msgfmt.c
+@@ -333,6 +333,8 @@ int main(int argc, char**argv) {
+ mode = m_desktop;
+ } else if(streq(A+2, "xml")) {
+ mode = m_xml;
++ } else if(streq(A+2, "keyword")) {
++ arg++;
+ } else if((locale = strstarts(A+2, "locale="))) {
+ } else if(streq(A+2, "check")) {
+ strict = true;