summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-07 13:44:12 +0000
committerZach van Rijn <me@zv.io>2022-05-07 13:44:12 +0000
commit4f5bdac8848d6b711afe33c23e05e2da3307e57c (patch)
treecefdb40be6c885591d7aa71d2c6a3012c286dff2 /system
parent8b17a4a9414eace2898ef062967efc4cad4d58d0 (diff)
downloadpackages-4f5bdac8848d6b711afe33c23e05e2da3307e57c.tar.gz
packages-4f5bdac8848d6b711afe33c23e05e2da3307e57c.tar.bz2
packages-4f5bdac8848d6b711afe33c23e05e2da3307e57c.tar.xz
packages-4f5bdac8848d6b711afe33c23e05e2da3307e57c.zip
system/grep: add patch for 32-bit ppc. fixes #671.
Diffstat (limited to 'system')
-rw-r--r--system/grep/APKBUILD6
-rw-r--r--system/grep/musl-ppc32.patch12
2 files changed, 16 insertions, 2 deletions
diff --git a/system/grep/APKBUILD b/system/grep/APKBUILD
index 82c66db34..dd6ef54a6 100644
--- a/system/grep/APKBUILD
+++ b/system/grep/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=grep
pkgver=3.7
-pkgrel=0
+pkgrel=1
pkgdesc="Pattern matching utilities"
url="https://www.gnu.org/software/grep/grep.html"
arch="all"
@@ -15,6 +15,7 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://mirrors.kernel.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
gnulib-tests-dont-require-gpg-passphrase.patch
fix-tests.patch
+ musl-ppc32.patch
"
build() {
@@ -42,4 +43,5 @@ package() {
sha512sums="e9e45dcd40af8367f819f2b93c5e1b4e98a251a9aa251841fa67a875380fae52cfa27c68c6dbdd6a4dde1b1017ee0f6b9833ef6dd6e419d32d71b6df5e972b82 grep-3.7.tar.xz
fd97fccd661befc558b3afb3e32c82dd2cef511a05e6129d49540599297c1b59ab1f109e63a12f585a2348c26c28fb98330c348829d1fe61cf8149d0dd1c989c gnulib-tests-dont-require-gpg-passphrase.patch
-9ba6b01c0c74933299afb469dadd2ea0c7e24befa34c691671a576063e32a1f0c735541e5e2bb0073d8afd814790909f7f895827aa8a2fbacdfcae380a7bcb11 fix-tests.patch"
+9ba6b01c0c74933299afb469dadd2ea0c7e24befa34c691671a576063e32a1f0c735541e5e2bb0073d8afd814790909f7f895827aa8a2fbacdfcae380a7bcb11 fix-tests.patch
+203765b90acf7fffaf8da9906e8d772ff81e074bf6585e35c713df107e9537c0a915013a327b3f770cc06c3a85f5ef55d6be32bbfdf6ce91a1aa1d4ac47e8ef3 musl-ppc32.patch"
diff --git a/system/grep/musl-ppc32.patch b/system/grep/musl-ppc32.patch
new file mode 100644
index 000000000..7f4149408
--- /dev/null
+++ b/system/grep/musl-ppc32.patch
@@ -0,0 +1,12 @@
+diff -ur a/lib/sigsegv.c b/lib/sigsegv.c
+--- a/lib/sigsegv.c 2022-05-07 13:35:30.000000000 +0000
++++ b/lib/sigsegv.c 2022-05-07 13:38:33.030000000 +0000
+@@ -222,7 +222,7 @@
+ # if 0
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
+ # else
+-# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
++# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ # endif
+ # endif
+