summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 00:33:10 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 00:33:10 -0500
commit6ba5a0b49b0e93a8db97bd9afc5afb2a18588e07 (patch)
tree11d20e6a9a2ed44c5cac4483c0269f47dbc0148b /system
parent8f427be8c954ca358fb56d82cb9dc9329d024548 (diff)
downloadpackages-6ba5a0b49b0e93a8db97bd9afc5afb2a18588e07.tar.gz
packages-6ba5a0b49b0e93a8db97bd9afc5afb2a18588e07.tar.bz2
packages-6ba5a0b49b0e93a8db97bd9afc5afb2a18588e07.tar.xz
packages-6ba5a0b49b0e93a8db97bd9afc5afb2a18588e07.zip
boost: move to user/
Diffstat (limited to 'system')
-rw-r--r--system/boost/APKBUILD145
-rw-r--r--system/boost/boost-1.57.0-python-abi_letters.patch62
-rw-r--r--system/boost/boost-1.57.0-python-libpython_dep.patch13
-rw-r--r--system/boost/dual-python.patch27
-rw-r--r--system/boost/libressl.patch146
5 files changed, 0 insertions, 393 deletions
diff --git a/system/boost/APKBUILD b/system/boost/APKBUILD
deleted file mode 100644
index 9024cb9fe..000000000
--- a/system/boost/APKBUILD
+++ /dev/null
@@ -1,145 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=boost
-pkgver=1.62.0
-_pkgver="${pkgver//./_}"
-pkgrel=6
-pkgdesc="Free peer-reviewed portable C++ source libraries"
-url="http://www.boost.org/"
-arch="all"
-license="custom"
-options="!check" # No test suite.
-depends=""
-depends_dev="linux-headers"
-makedepends="$depends_dev python3-dev flex bison bzip2-dev zlib-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$_pkgver.tar.bz2
- libressl.patch
- boost-1.57.0-python-abi_letters.patch
- boost-1.57.0-python-libpython_dep.patch
- "
-builddir="$srcdir/${pkgname}_${_pkgver}"
-
-_libs="date_time
- filesystem
- graph
- iostreams
- math
- prg_exec_monitor
- program_options
- python3
- random
- regex
- serialization
- signals
- system
- thread
- unit_test_framework
- wave
- wserialization
- "
-for _lib in $_libs; do
- subpackages="$subpackages $pkgname-$_lib:_boostlib"
-done
-
-prepare() {
- default_prepare || return 1
-
- cd "$builddir"
-
- PY3_VERSION="$(_pyversion python3)"
- abiflags=$(python3-config --abiflags)
-
-
- # create user-config.jam
- cat > user-config.jam <<-__EOF__
-
- using gcc : : $CC : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
- using python : ${PY3_VERSION} : /usr/bin/python3 : /usr/include/python${PY3_VERSION}m : : : : $abiflags ;
-
- __EOF__
-}
-
-case "$CARCH" in
- armhf|aarch64) _boostarch=arm ;;
- ppc64*) _boostarch=ppc ;;
- s390x) _boostarch=s390 ;;
- pmmx) _boostarch=x86 ;;
- *) _boostarch=$CARCH ;;
-esac
-_enginedir=tools/build/src/engine
-_bjam="${builddir}/$_enginedir/bin.linux${_boostarch}/bjam"
-[ "$_boostarch" = "s390" ] && _bjam="${builddir}/$_enginedir/bin.linux390/bjam" && \
- _options_s390="--without-context --without-coroutine --without-coroutine2"
-
-_options="--user-config=\"$builddir/user-config.jam\"
- --prefix=\"$pkgdir/usr\"
- release
- debug-symbols=off
- threading=single,multi
- runtime-link=shared
- link=shared,static
- cflags=-fno-strict-aliasing
- -sPYTHON_ROOT=/usr
- -sTOOLS=gcc
- --layout=tagged
- -q
- -j${JOBS:-2}
- ${_options_s390}
- "
-
-build() {
- export BOOST_ROOT="$builddir"
-
- msg "Building bjam"
- cd "$builddir"/$_enginedir
- CC= ./build.sh cc || return 1
-
- msg "Building bcp"
- cd "$builddir"/tools/bcp
- "$_bjam" -j${JOBS:-2} || return 1
-
- msg "Building boost"
- cd "$builddir"
- "$_bjam" $_options
-}
-
-package() {
- export BOOST_ROOT="$builddir"
- cd "$builddir"
-
- install -Dm755 $_bjam \
- "$pkgdir"/usr/bin/bjam || return 1
-
- install -Dm755 dist/bin/bcp "$pkgdir"/usr/bin/bcp || return 1
-
- install -Dm644 LICENSE_1_0.txt \
- "$pkgdir"/usr/share/licenses/$pkgname/LICENSE_1_0.txt || return 1
-
- "$pkgdir"/usr/bin/bjam $_options \
- --includedir="$pkgdir"/usr/include \
- --libdir="$pkgdir"/usr/lib \
- install || return 1
-
- cd libs/python/pyste/install
- python3 setup.py install --root="$pkgdir" || return 1
-}
-
-_boostlib() {
- local name="${subpkgname#$pkgname-}"
- pkgdesc="Boost $name library"
- case "$name" in
- python*) depends="$depends $name"
- esac
-
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libboost_$name* "$subpkgdir"/usr/lib/
-}
-
-_pyversion() {
- $1 -c 'import sys; print("%i.%i" % (sys.version_info.major, sys.version_info.minor))'
-}
-
-sha512sums="5385ae3d5255a433a704169ad454d8dc2b0b5bcae3fb23defd6570df4ff7d845cf9fcbeebccdc1c5db0eec9f82ee3d90040de9507c8167467c635d3b215463be boost_1_62_0.tar.bz2
-5804c344b5e5ece17811e744f1965c58840b6695a084dd09c23c9db380f3cbfbca201d6c595b5379bc12ff6f285794509799d28864df6037db6212c63adb2207 libressl.patch
-d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch
-132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch"
diff --git a/system/boost/boost-1.57.0-python-abi_letters.patch b/system/boost/boost-1.57.0-python-abi_letters.patch
deleted file mode 100644
index 7df3ee704..000000000
--- a/system/boost/boost-1.57.0-python-abi_letters.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- boost_1_57_0/tools/build/src/tools/python.jam 2013-05-21 06:14:18.000000000 +0200
-+++ boost_1_55_0/tools/build/src/tools/python.jam 2014-05-29 19:09:12.115413877 +0200
-@@ -94,7 +94,7 @@ feature.feature pythonpath : : free opti
- # using python : 2.3 : /usr/local/bin/python ;
- #
- rule init ( version ? : cmd-or-prefix ? : includes * : libraries ?
-- : condition * : extension-suffix ? )
-+ : condition * : extension-suffix ? : abi-letters ? )
- {
- project.push-current $(.project) ;
-
-@@ -107,7 +107,7 @@ rule init ( version ? : cmd-or-prefix ?
- }
- }
-
-- configure $(version) : $(cmd-or-prefix) : $(includes) : $(libraries) : $(condition) : $(extension-suffix) ;
-+ configure $(version) : $(cmd-or-prefix) : $(includes) : $(libraries) : $(condition) : $(extension-suffix) : $(abi-letters) ;
-
- project.pop-current ;
- }
-@@ -653,7 +653,7 @@ local rule system-library-dependencies (
-
- # Declare a target to represent Python's library.
- #
--local rule declare-libpython-target ( version ? : requirements * )
-+local rule declare-libpython-target ( version ? : requirements * : abi-letters ? )
- {
- # Compute the representation of Python version in the name of Python's
- # library file.
-@@ -677,13 +677,13 @@ local rule declare-libpython-target ( ve
- }
-
- # Declare it.
-- lib python.lib : : <name>python$(lib-version) $(requirements) ;
-+ lib python.lib : : <name>python$(lib-version)$(abi-letters) $(requirements) ;
- }
-
-
- # Implementation of init.
- local rule configure ( version ? : cmd-or-prefix ? : includes * : libraries ? :
-- condition * : extension-suffix ? )
-+ condition * : extension-suffix ? : abi-letters ? )
- {
- local prefix ;
- local exec-prefix ;
-@@ -699,6 +699,7 @@ local rule configure ( version ? : cmd-o
- extension-suffix ?= _d ;
- }
- extension-suffix ?= "" ;
-+ abi-letters ?= "" ;
-
- # Normalize and dissect any version number.
- local major-minor ;
-@@ -922,7 +923,7 @@ local rule configure ( version ? : cmd-o
- }
- else
- {
-- declare-libpython-target $(version) : $(target-requirements) ;
-+ declare-libpython-target $(version) : $(target-requirements) : $(abi-letters) ;
-
- # This is an evil hack. On, Windows, when Python is embedded, nothing
- # seems to set up sys.path to include Python's standard library
diff --git a/system/boost/boost-1.57.0-python-libpython_dep.patch b/system/boost/boost-1.57.0-python-libpython_dep.patch
deleted file mode 100644
index 57bfc2677..000000000
--- a/system/boost/boost-1.57.0-python-libpython_dep.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: boost_1_57_0/tools/build/src/tools/python.jam
-===================================================================
---- boost_1_57_0/tools/build/src/tools/python.jam (revision 50406)
-+++ boost_1_57_0/tools/build/src/tools/python.jam (working copy)
-@@ -994,7 +994,7 @@
- else
- {
- alias python_for_extensions
-- :
-+ : python
- : $(target-requirements)
- :
- : $(usage-requirements)
diff --git a/system/boost/dual-python.patch b/system/boost/dual-python.patch
deleted file mode 100644
index 6a0647888..000000000
--- a/system/boost/dual-python.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/tools/build/src/tools/python.jam b/tools/build/src/tools/python.jam
-index cbd6419..0c29df6 100644
---- a/tools/build/src/tools/python.jam
-+++ b/tools/build/src/tools/python.jam
-@@ -907,14 +907,14 @@ local rule configure ( version ? : cmd-or-prefix ? : includes * : libraries ? :
- # for a particular target OS as the default. This makes it so that we can
- # select a python interpreter with only knowledge of the target OS. And hence
- # can configure different Pythons based on the target OS only.
-- local toolset-requirements = [ toolset.requirements ] ;
-- local toolset-target-os-requirements
-- = [ property.evaluate-conditionals-in-context
-- [ $(toolset-requirements).raw ] : <target-os>$(target-os) ] ;
-- if ! <python> in $(toolset-target-os-requirements:G)
-- {
-- toolset.add-requirements <target-os>$(target-os):<python>$(version:E=default) ;
-- }
-+# local toolset-requirements = [ toolset.requirements ] ;
-+# local toolset-target-os-requirements
-+# = [ property.evaluate-conditionals-in-context
-+# [ $(toolset-requirements).raw ] : <target-os>$(target-os) ] ;
-+# if ! <python> in $(toolset-target-os-requirements:G)
-+# {
-+# toolset.add-requirements <target-os>$(target-os):<python>$(version:E=default) ;
-+# }
-
- # Register the right suffix for extensions.
- register-extension-suffix $(extension-suffix) : $(target-requirements) ;
diff --git a/system/boost/libressl.patch b/system/boost/libressl.patch
deleted file mode 100644
index 30c13bfcc..000000000
--- a/system/boost/libressl.patch
+++ /dev/null
@@ -1,146 +0,0 @@
-diff --git a/boost/asio/ssl/detail/impl/engine.ipp b/boost/asio/ssl/detail/impl/engine.ipp
-index f15f2e3..d33935f 100644
---- a/boost/asio/ssl/detail/impl/engine.ipp
-+++ b/boost/asio/ssl/detail/impl/engine.ipp
-@@ -209,7 +209,7 @@ const boost::system::error_code& engine::map_error_code(
-
- // SSL v2 doesn't provide a protocol-level shutdown, so an eof on the
- // underlying transport is passed through.
--#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
- if (ssl_->version == SSL2_VERSION)
- return ec;
- #endif // (OPENSSL_VERSION_NUMBER < 0x10100000L)
-diff --git a/boost/asio/ssl/detail/impl/openssl_init.ipp b/boost/asio/ssl/detail/impl/openssl_init.ipp
-index 94b67f3..acbd926 100644
---- a/boost/asio/ssl/detail/impl/openssl_init.ipp
-+++ b/boost/asio/ssl/detail/impl/openssl_init.ipp
-@@ -40,7 +40,7 @@ public:
- ::SSL_load_error_strings();
- ::OpenSSL_add_all_algorithms();
-
--#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
- mutexes_.resize(::CRYPTO_num_locks());
- for (size_t i = 0; i < mutexes_.size(); ++i)
- mutexes_[i].reset(new boost::asio::detail::mutex);
-@@ -68,7 +68,7 @@ public:
- #if (OPENSSL_VERSION_NUMBER < 0x10000000L)
- ::CRYPTO_set_id_callback(0);
- #endif // (OPENSSL_VERSION_NUMBER < 0x10000000L)
--#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
- ::CRYPTO_set_locking_callback(0);
- ::ERR_free_strings();
- ::EVP_cleanup();
-@@ -76,7 +76,7 @@ public:
- #endif // (OPENSSL_VERSION_NUMBER < 0x10100000L)
- #if (OPENSSL_VERSION_NUMBER < 0x10000000L)
- ::ERR_remove_state(0);
--#elif (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+#elif (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
- ::ERR_remove_thread_state(NULL);
- #endif // (OPENSSL_VERSION_NUMBER < 0x10000000L)
- #if (OPENSSL_VERSION_NUMBER >= 0x10002000L) \
-@@ -117,7 +117,7 @@ private:
- }
- #endif // (OPENSSL_VERSION_NUMBER < 0x10000000L)
-
--#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
- static void openssl_locking_func(int mode, int n,
- const char* /*file*/, int /*line*/)
- {
-diff --git a/boost/asio/ssl/error.hpp b/boost/asio/ssl/error.hpp
-index 7f85fbd..7e07e65 100644
---- a/boost/asio/ssl/error.hpp
-+++ b/boost/asio/ssl/error.hpp
-@@ -44,7 +44,7 @@ enum stream_errors
- #if defined(GENERATING_DOCUMENTATION)
- /// The underlying stream closed before the ssl stream gracefully shut down.
- stream_truncated
--#elif (OPENSSL_VERSION_NUMBER < 0x10100000L) && !defined(OPENSSL_IS_BORINGSSL)
-+#elif ((OPENSSL_VERSION_NUMBER < 0x10100000L) && !defined(OPENSSL_IS_BORINGSSL)) || defined(LIBRESSL_VERSION_NUMBER)
- stream_truncated = ERR_PACK(ERR_LIB_SSL, 0, SSL_R_SHORT_READ)
- #else
- stream_truncated = 1
-diff --git a/boost/asio/ssl/impl/context.ipp b/boost/asio/ssl/impl/context.ipp
-index aea2cbd..3ef8c86 100644
---- a/boost/asio/ssl/impl/context.ipp
-+++ b/boost/asio/ssl/impl/context.ipp
-@@ -130,7 +130,7 @@ context::context(context::method m)
- case context::sslv23_server:
- handle_ = ::SSL_CTX_new(::SSLv23_server_method());
- break;
--#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
- #if defined(SSL_TXT_TLSV1_1)
- case context::tlsv11:
- handle_ = ::SSL_CTX_new(::TLSv1_1_method());
-@@ -228,7 +228,7 @@ context::~context()
- {
- if (handle_)
- {
--#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
- void* cb_userdata = ::SSL_CTX_get_default_passwd_cb_userdata(handle_);
- #else // (OPENSSL_VERSION_NUMBER >= 0x10100000L)
- void* cb_userdata = handle_->default_passwd_callback_userdata;
-@@ -239,7 +239,7 @@ context::~context()
- static_cast<detail::password_callback_base*>(
- cb_userdata);
- delete callback;
--#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
- ::SSL_CTX_set_default_passwd_cb_userdata(handle_, 0);
- #else // (OPENSSL_VERSION_NUMBER >= 0x10100000L)
- handle_->default_passwd_callback_userdata = 0;
-@@ -578,7 +578,7 @@ boost::system::error_code context::use_certificate_chain(
- bio_cleanup bio = { make_buffer_bio(chain) };
- if (bio.p)
- {
--#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
- pem_password_cb* callback = ::SSL_CTX_get_default_passwd_cb(handle_);
- void* cb_userdata = ::SSL_CTX_get_default_passwd_cb_userdata(handle_);
- #else // (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-@@ -682,7 +682,7 @@ boost::system::error_code context::use_private_key(
- {
- ::ERR_clear_error();
-
--#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
- pem_password_cb* callback = ::SSL_CTX_get_default_passwd_cb(handle_);
- void* cb_userdata = ::SSL_CTX_get_default_passwd_cb_userdata(handle_);
- #else // (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-@@ -749,7 +749,7 @@ boost::system::error_code context::use_rsa_private_key(
- {
- ::ERR_clear_error();
-
--#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
- pem_password_cb* callback = ::SSL_CTX_get_default_passwd_cb(handle_);
- void* cb_userdata = ::SSL_CTX_get_default_passwd_cb_userdata(handle_);
- #else // (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-@@ -988,7 +988,7 @@ int context::verify_callback_function(int preverified, X509_STORE_CTX* ctx)
- boost::system::error_code context::do_set_password_callback(
- detail::password_callback_base* callback, boost::system::error_code& ec)
- {
--#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
- void* old_callback = ::SSL_CTX_get_default_passwd_cb_userdata(handle_);
- ::SSL_CTX_set_default_passwd_cb_userdata(handle_, callback);
- #else // (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-diff --git a/boost/asio/ssl/impl/error.ipp b/boost/asio/ssl/impl/error.ipp
-index e82afba..1629794 100644
---- a/boost/asio/ssl/impl/error.ipp
-+++ b/boost/asio/ssl/impl/error.ipp
-@@ -53,7 +53,7 @@ const boost::system::error_category& get_ssl_category()
- namespace ssl {
- namespace error {
-
--#if (OPENSSL_VERSION_NUMBER < 0x10100000L) && !defined(OPENSSL_IS_BORINGSSL)
-+#if ((OPENSSL_VERSION_NUMBER < 0x10100000L) && !defined(OPENSSL_IS_BORINGSSL)) || defined(LIBRESSL_VERSION_NUMBER)
-
- const boost::system::error_category& get_stream_category()
- {