summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-05-26 21:15:38 -0400
committerMax Rees <maxcrees@me.com>2018-05-26 21:15:38 -0400
commit92563f5289c64332795cd296e2a9187a773f470c (patch)
treeff35e77691356aa930b9892b2b67bf538318367e /system
parent36e31b560eb3b4a6154deecfbf91f27494de21b7 (diff)
downloadpackages-92563f5289c64332795cd296e2a9187a773f470c.tar.gz
packages-92563f5289c64332795cd296e2a9187a773f470c.tar.bz2
packages-92563f5289c64332795cd296e2a9187a773f470c.tar.xz
packages-92563f5289c64332795cd296e2a9187a773f470c.zip
system/{bash-binsh,dash-binsh,build-tools}: add provider_priority
This makes bash-binsh the default and should fix compatibility in /usr/bin/abuild for populating a chroot with only abuild, alpine-base (adelie-base), build-base (build-tools), and git
Diffstat (limited to 'system')
-rw-r--r--system/bash/APKBUILD3
-rw-r--r--system/build-tools/APKBUILD3
-rw-r--r--system/dash/APKBUILD3
3 files changed, 6 insertions, 3 deletions
diff --git a/system/bash/APKBUILD b/system/bash/APKBUILD
index c5a476b1a..0e45c8a96 100644
--- a/system/bash/APKBUILD
+++ b/system/bash/APKBUILD
@@ -6,7 +6,7 @@ pkgver=4.4.12
_patchlevel=${pkgver##*.}
_myver=${pkgver%.*}
_patchbase=${_myver/./}
-pkgrel=2
+pkgrel=3
pkgdesc="The GNU Bourne Again shell"
url="http://www.gnu.org/software/bash/bash.html"
arch="all"
@@ -94,6 +94,7 @@ package() {
binsh() {
pkgdesc="Use bash as /bin/sh"
provides="/bin/sh"
+ provider_priority=10
mkdir -p "$subpkgdir"/bin
ln -s /bin/bash "$subpkgdir"/bin/sh
}
diff --git a/system/build-tools/APKBUILD b/system/build-tools/APKBUILD
index c8b546a1a..416d6ccca 100644
--- a/system/build-tools/APKBUILD
+++ b/system/build-tools/APKBUILD
@@ -3,7 +3,7 @@
pkgname=build-tools
pkgver=1.0
-pkgrel=4
+pkgrel=5
pkgdesc="Meta-package for user development utilities"
url="https://adelielinux.org/"
arch="noarch"
@@ -25,6 +25,7 @@ makedepends=""
makedepends_host="$depends"
options="!check"
provides="build-base"
+provider_priority=10
source=""
build() {
diff --git a/system/dash/APKBUILD b/system/dash/APKBUILD
index f22c6c8eb..c1fbec305 100644
--- a/system/dash/APKBUILD
+++ b/system/dash/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dash
pkgver=0.5.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="Small and fast POSIX-compliant shell"
url="http://gondor.apana.org.au/~herbert/dash/"
arch="all"
@@ -37,6 +37,7 @@ package() {
binsh() {
pkgdesc="Use dash as /bin/sh"
provides="/bin/sh"
+ provider_priority=1
mkdir -p "$subpkgdir"/bin
ln -s dash "$subpkgdir"/bin/sh
}