summaryrefslogtreecommitdiff
path: root/user/abiword/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-01-07 22:08:41 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-01-07 22:08:41 +0000
commitd0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f (patch)
treeeee20c0afd09b50da7c4ef94e7775b85dd4aca18 /user/abiword/APKBUILD
parent14cd2a940d42e9a28c6c51ee7fb8fde9e64efb3e (diff)
parent677a7de7f445dad6dab7c8531029f3e45fab8a0a (diff)
downloadpackages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.gz
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.bz2
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.xz
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.zip
Merge branch 'abiword' into 'master'
New packages: AbiWord + dependencies APKBUILDs converted from Alpine, with some changes to bring AbiWord's plugins into a single `abiword` package and cleaning of the licence lines. This has been tested on x86_64 (2007 Macbook Pro), and AbiWord shows some rendering flicker, which I'm not sure how to debug, but otherwise appears to run fine. See merge request !141
Diffstat (limited to 'user/abiword/APKBUILD')
-rw-r--r--user/abiword/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
new file mode 100644
index 000000000..351961055
--- /dev/null
+++ b/user/abiword/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=abiword
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="A fully-featured word processor"
+url="https://www.abisource.com"
+arch="all"
+options="!check" # Test suite requires valgrind, etc
+license="GPL-2.0+"
+makedepends="bzip2-dev enchant-dev fribidi-dev goffice-dev gtk+3.0-dev
+ libgsf-dev libjpeg-turbo-dev librsvg-dev libxslt-dev pcre-dev
+ popt-dev wv-dev"
+
+# openxml plugin
+makedepends="$makedepends boost-dev"
+
+# collab plugin
+makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
+
+subpackages="$pkgname-dev $pkgname-doc"
+
+_plugins="applix babelfish bmp clarisworks collab docbook eml epub \
+ freetranslation garble gdict gimp google hancom hrtext iscii kword \
+ latex loadbindings mht mif mswrite openwriter openxml opml paint \
+ passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
+ xslfo"
+
+source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+ fix-black-drawing-regression.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-plugins="$_plugins"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
+cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch"