summaryrefslogtreecommitdiff
path: root/user/abiword/fix-black-drawing-regression.patch
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-01-07 22:08:41 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-01-07 22:08:41 +0000
commitd0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f (patch)
treeeee20c0afd09b50da7c4ef94e7775b85dd4aca18 /user/abiword/fix-black-drawing-regression.patch
parent14cd2a940d42e9a28c6c51ee7fb8fde9e64efb3e (diff)
parent677a7de7f445dad6dab7c8531029f3e45fab8a0a (diff)
downloadpackages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.gz
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.bz2
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.xz
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.zip
Merge branch 'abiword' into 'master'
New packages: AbiWord + dependencies APKBUILDs converted from Alpine, with some changes to bring AbiWord's plugins into a single `abiword` package and cleaning of the licence lines. This has been tested on x86_64 (2007 Macbook Pro), and AbiWord shows some rendering flicker, which I'm not sure how to debug, but otherwise appears to run fine. See merge request !141
Diffstat (limited to 'user/abiword/fix-black-drawing-regression.patch')
-rw-r--r--user/abiword/fix-black-drawing-regression.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/user/abiword/fix-black-drawing-regression.patch b/user/abiword/fix-black-drawing-regression.patch
new file mode 100644
index 000000000..dbce8c696
--- /dev/null
+++ b/user/abiword/fix-black-drawing-regression.patch
@@ -0,0 +1,54 @@
+From cec2fda355b67b5b814a803c5ed128c425cbb030 Mon Sep 17 00:00:00 2001
+From: Hubert Figuiere <hub@figuiere.net>
+Date: Thu, 8 Dec 2016 02:03:10 +0000
+Subject: [PATCH] Bug 13815 - draw event should return TRUE
+
+This fix the black drawing regression with Gtk3.22
+
+git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/branches/ABI-3-0-0-STABLE@35394 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
+---
+ src/af/xap/gtk/xap_UnixFrameImpl.cpp | 6 +++---
+ src/af/xap/gtk/xap_UnixFrameImpl.h | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+index 780000e..10f8e00 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
+ }
+
+ #if GTK_CHECK_VERSION(3,0,0)
+-gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
++gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
+ #else
+-gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
++gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ #endif
+ {
+ XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
+@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ pView->draw(&rClip);
+ #endif
+ }
+- return FALSE;
++ return TRUE;
+ }
+
+ static bool bScrollWait = false;
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
+index 30ee5d8..a0ff57f 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.h
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
+@@ -152,9 +152,9 @@ class XAP_UnixFrameImpl : public XAP_FrameImpl
+ static gint key_release_event(GtkWidget* w, GdkEventKey* e);
+ static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
+ #if GTK_CHECK_VERSION(3,0,0)
+- static gint draw(GtkWidget * w, cairo_t * cr);
++ static gboolean draw(GtkWidget * w, cairo_t * cr);
+ #else
+- static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
++ static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
+ #endif
+ static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
+ static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);