summaryrefslogtreecommitdiff
path: root/user/abiword
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-01 18:02:54 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit9684b20847311f06408fe606dbbe3d5075eedfb6 (patch)
tree2290273ff4b298b4c42f62cd670fe248948f29c8 /user/abiword
parent89a6f3b1e6ba7a5ee6276fbb17e928f016bed313 (diff)
downloadpackages-9684b20847311f06408fe606dbbe3d5075eedfb6.tar.gz
packages-9684b20847311f06408fe606dbbe3d5075eedfb6.tar.bz2
packages-9684b20847311f06408fe606dbbe3d5075eedfb6.tar.xz
packages-9684b20847311f06408fe606dbbe3d5075eedfb6.zip
user/abiword: bump { 3.0.4 --> 3.0.5 }. patch bad cast. fixes #477.
Diffstat (limited to 'user/abiword')
-rw-r--r--user/abiword/APKBUILD9
-rw-r--r--user/abiword/fix-bad-cast.patch12
2 files changed, 18 insertions, 3 deletions
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
index a76ef2557..990cd9156 100644
--- a/user/abiword/APKBUILD
+++ b/user/abiword/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=abiword
-pkgver=3.0.4
+pkgver=3.0.5
pkgrel=0
pkgdesc="A fully-featured word processor"
url="https://www.abisource.com"
@@ -22,7 +22,9 @@ _plugins="applix babelfish bmp clarisworks collab docbook eml epub \
latex loadbindings mht mif mswrite openwriter openxml opml paint \
passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
xslfo"
-source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz"
+source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+ fix-bad-cast.patch
+ "
build() {
./configure \
@@ -39,4 +41,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="121708e010cef6722cab5622dc762f2f92c46e43b65b90b881b4f25ff32c1696fa2d281a3a6f2c04d5b9231bbbd0040281e9d4d7e594ec0ace6caae9c9021ec4 abiword-3.0.4.tar.gz"
+sha512sums="a2484268901ff47307c9d1f1928622e364f1006f22ce38257c585144df9411dfe3c2dea28c1f1f50a6e545e8cc579cce34117a89dfa771e20312e3ea1a9989d6 abiword-3.0.5.tar.gz
+89edeed246f937e4f198068ed9861e155662d346fb1534d2ed676cbd782de22a691d2b045989942bd715cbfc3750cf9d7615065816b970695597361ae4a9d55e fix-bad-cast.patch"
diff --git a/user/abiword/fix-bad-cast.patch b/user/abiword/fix-bad-cast.patch
new file mode 100644
index 000000000..fdecb21c5
--- /dev/null
+++ b/user/abiword/fix-bad-cast.patch
@@ -0,0 +1,12 @@
+diff -ur a/src/af/xap/xp/xap_Dialog.cpp b/src/af/xap/xp/xap_Dialog.cpp
+--- a/src/af/xap/xp/xap_Dialog.cpp 2022-02-01 17:49:27.650000000 +0000
++++ b/src/af/xap/xp/xap_Dialog.cpp 2022-02-01 17:52:14.000000000 +0000
+@@ -267,7 +267,7 @@
+ // This function constructs and returns the window name of a modeless dialog by
+ // concatenating the active frame with the dialog name
+
+- *pWindowName = (char) NULL;
++ *pWindowName = 0; // https://gitlab.gnome.org/World/AbiWord/-/commit/857cd86def49fe8557cfe123830c4d5a61eee732.patch
+ UT_UTF8String wn = UT_UTF8String(pDialogName);
+
+ XAP_Frame* pFrame = getActiveFrame();