summaryrefslogtreecommitdiff
path: root/user/abiword
diff options
context:
space:
mode:
authormultiplexd <multi@in-addr.xyz>2019-01-07 20:45:49 +0000
committermultiplexd <multi@in-addr.xyz>2019-01-07 21:22:49 +0000
commit677a7de7f445dad6dab7c8531029f3e45fab8a0a (patch)
tree83b0da1d1c5e56bb50a279a7250bbc0e605cece2 /user/abiword
parentaaed1d384ec219669ec3680e1f9e6b3a42d775e0 (diff)
downloadpackages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.tar.gz
packages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.tar.bz2
packages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.tar.xz
packages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.zip
user/abiword: new package
Diffstat (limited to 'user/abiword')
-rw-r--r--user/abiword/APKBUILD50
-rw-r--r--user/abiword/fix-black-drawing-regression.patch54
2 files changed, 104 insertions, 0 deletions
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
new file mode 100644
index 000000000..351961055
--- /dev/null
+++ b/user/abiword/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=abiword
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="A fully-featured word processor"
+url="https://www.abisource.com"
+arch="all"
+options="!check" # Test suite requires valgrind, etc
+license="GPL-2.0+"
+makedepends="bzip2-dev enchant-dev fribidi-dev goffice-dev gtk+3.0-dev
+ libgsf-dev libjpeg-turbo-dev librsvg-dev libxslt-dev pcre-dev
+ popt-dev wv-dev"
+
+# openxml plugin
+makedepends="$makedepends boost-dev"
+
+# collab plugin
+makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
+
+subpackages="$pkgname-dev $pkgname-doc"
+
+_plugins="applix babelfish bmp clarisworks collab docbook eml epub \
+ freetranslation garble gdict gimp google hancom hrtext iscii kword \
+ latex loadbindings mht mif mswrite openwriter openxml opml paint \
+ passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
+ xslfo"
+
+source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+ fix-black-drawing-regression.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-plugins="$_plugins"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
+cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch"
diff --git a/user/abiword/fix-black-drawing-regression.patch b/user/abiword/fix-black-drawing-regression.patch
new file mode 100644
index 000000000..dbce8c696
--- /dev/null
+++ b/user/abiword/fix-black-drawing-regression.patch
@@ -0,0 +1,54 @@
+From cec2fda355b67b5b814a803c5ed128c425cbb030 Mon Sep 17 00:00:00 2001
+From: Hubert Figuiere <hub@figuiere.net>
+Date: Thu, 8 Dec 2016 02:03:10 +0000
+Subject: [PATCH] Bug 13815 - draw event should return TRUE
+
+This fix the black drawing regression with Gtk3.22
+
+git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/branches/ABI-3-0-0-STABLE@35394 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
+---
+ src/af/xap/gtk/xap_UnixFrameImpl.cpp | 6 +++---
+ src/af/xap/gtk/xap_UnixFrameImpl.h | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+index 780000e..10f8e00 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
+ }
+
+ #if GTK_CHECK_VERSION(3,0,0)
+-gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
++gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
+ #else
+-gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
++gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ #endif
+ {
+ XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
+@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ pView->draw(&rClip);
+ #endif
+ }
+- return FALSE;
++ return TRUE;
+ }
+
+ static bool bScrollWait = false;
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
+index 30ee5d8..a0ff57f 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.h
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
+@@ -152,9 +152,9 @@ class XAP_UnixFrameImpl : public XAP_FrameImpl
+ static gint key_release_event(GtkWidget* w, GdkEventKey* e);
+ static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
+ #if GTK_CHECK_VERSION(3,0,0)
+- static gint draw(GtkWidget * w, cairo_t * cr);
++ static gboolean draw(GtkWidget * w, cairo_t * cr);
+ #else
+- static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
++ static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
+ #endif
+ static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
+ static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);