summaryrefslogtreecommitdiff
path: root/user/akonadi-notes/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-12 03:07:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-12 03:07:24 -0500
commit8e083ea3bd1a918b47fe73a6764ec483e4dd6bc2 (patch)
treeaf6afcbbfe6ce6f7acc6b17088e5adfc13c0e152 /user/akonadi-notes/APKBUILD
parent3ed613156c4a44d8962e33e44028da555fe30aec (diff)
downloadpackages-8e083ea3bd1a918b47fe73a6764ec483e4dd6bc2.tar.gz
packages-8e083ea3bd1a918b47fe73a6764ec483e4dd6bc2.tar.bz2
packages-8e083ea3bd1a918b47fe73a6764ec483e4dd6bc2.tar.xz
packages-8e083ea3bd1a918b47fe73a6764ec483e4dd6bc2.zip
user/akonadi-notes: new package
Diffstat (limited to 'user/akonadi-notes/APKBUILD')
-rw-r--r--user/akonadi-notes/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/akonadi-notes/APKBUILD b/user/akonadi-notes/APKBUILD
new file mode 100644
index 000000000..02d777aba
--- /dev/null
+++ b/user/akonadi-notes/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=akonadi-notes
+pkgver=17.08.1
+pkgrel=0
+pkgdesc="Library for integrating notes into Akonadi"
+url="https://www.kde.org/"
+arch="all"
+license="LGPL-2.1"
+depends=""
+depends_dev="qt5-qtbase-dev ki18n-dev kmime-dev akonadi-dev"
+makedepends="$depends_dev cmake extra-cmake-modules"
+install=""
+subpackages="$pkgname-dev $pkgname-lang"
+source="http://download.kde.org/stable/applications/$pkgver/src/akonadi-notes-$pkgver.tar.xz"
+builddir="$srcdir/akonadi-notes-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="679af7c116a7bdd084fb39f3b678f194531bd14f09b7e815dc902552f2166832aaa64322fb143ed6b46afef13b2199dd9c1a919e69ba84ef607b081879904e6a akonadi-notes-17.08.1.tar.xz"