summaryrefslogtreecommitdiff
path: root/user/alsa-lib/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 05:44:24 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 05:44:24 -0600
commit8b046ee6a72c23d21ba324074e61b80e07d5a158 (patch)
tree775687837e0edd7bb5e9f1f6f19020ffff1c2729 /user/alsa-lib/APKBUILD
parent85be608956333271e65196181164ed1533dfe9d3 (diff)
downloadpackages-8b046ee6a72c23d21ba324074e61b80e07d5a158.tar.gz
packages-8b046ee6a72c23d21ba324074e61b80e07d5a158.tar.bz2
packages-8b046ee6a72c23d21ba324074e61b80e07d5a158.tar.xz
packages-8b046ee6a72c23d21ba324074e61b80e07d5a158.zip
user/alsa-lib: Bump to 1.2.1.2, use kernel headers
This removes the bundled headers from the source tree, forcing alsa-lib to compile against the kernel's headers. This should allow correct time64 operation on 32-bit systems.
Diffstat (limited to 'user/alsa-lib/APKBUILD')
-rw-r--r--user/alsa-lib/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/user/alsa-lib/APKBUILD b/user/alsa-lib/APKBUILD
index 81df9e2af..4f854e443 100644
--- a/user/alsa-lib/APKBUILD
+++ b/user/alsa-lib/APKBUILD
@@ -1,23 +1,19 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=alsa-lib
-pkgver=1.2.1
+pkgver=1.2.1.2
pkgrel=0
pkgdesc="Linux sound support system"
url="https://www.alsa-project.org/wiki/Main_Page"
arch="all"
license="LGPL-2.0+"
-subpackages="$pkgname-dev $pkgname-dbg"
+depends=""
makedepends="linux-headers"
+subpackages="$pkgname-dev $pkgname-dbg"
source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
ucm_add_limits_h.patch
remove-test.patch
"
-prepare() {
- rm src/compat/hsearch_r.c && touch src/compat/hsearch_r.c
- default_prepare
-}
-
build() {
./configure \
--build=$CBUILD \
@@ -31,6 +27,9 @@ build() {
--enable-aload \
--disable-dependency-tracking \
--without-versioned
+ rm -rf "$builddir"/include/sound
+ mkdir "$builddir"/include/sound
+ printf "all:\ncheck:\ninstall:\n" > "$builddir"/include/sound/Makefile
make
}
@@ -42,6 +41,6 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="a5bd60ed0cfca3911db534364554412c479d2cb6ded6c8e7011d2510797a6cbd10613d6e1d42cb589afec8e7408c8fd5465360ddd14df8701af7dc414961c19e alsa-lib-1.2.1.tar.bz2
+sha512sums="e8286fd55f63ee0d95513279d0885c287533de89b7af6c338413dec5d38ba4f5a15da1a4a4ce36e052614e4b730e3778782dab9979d82958283be17b48604913 alsa-lib-1.2.1.2.tar.bz2
3b37652d50809443b5f8e80f8d447108195b0cd66fd917805bb393fc091584b6f3dad4414f568742b61745617e7a695862058a0a0f93dcc31e4c97177a520352 ucm_add_limits_h.patch
-388443e7d9c90339b273a40205c5cbb14033ec16d357b52b0eaeb97e2f074fab100439f8cb2972011ac1580712448a4861ab2dec26653b55badf1caaaf207a59 remove-test.patch"
+0ce3c2b8a0a70e2dffb6d633b95c4aae74504cd694fe1507cbc409d931b5f733935b22de45e4adcf5a507587c9f80c60a6f0e798aac2ca2fbf0cbcdef0080079 remove-test.patch"