summaryrefslogtreecommitdiff
path: root/user/apr-util
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-07 02:40:53 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-07 02:40:53 +0000
commitfb406132ea3e792279435d801dc4da23dc8294ee (patch)
tree3bee626f3474a7ae5870783dff7ee8dda05c5a7c /user/apr-util
parentcbd19047ab4d7db5f86056d8b71fbc22176cc987 (diff)
downloadpackages-fb406132ea3e792279435d801dc4da23dc8294ee.tar.gz
packages-fb406132ea3e792279435d801dc4da23dc8294ee.tar.bz2
packages-fb406132ea3e792279435d801dc4da23dc8294ee.tar.xz
packages-fb406132ea3e792279435d801dc4da23dc8294ee.zip
user/*: Modernise / fix syntax / deps
Also, take APR
Diffstat (limited to 'user/apr-util')
-rw-r--r--user/apr-util/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/user/apr-util/APKBUILD b/user/apr-util/APKBUILD
index 36a8f4a59..6dd56ef3e 100644
--- a/user/apr-util/APKBUILD
+++ b/user/apr-util/APKBUILD
@@ -1,4 +1,4 @@
-# Maintainer:
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=apr-util
pkgver=1.6.1
pkgrel=0
@@ -6,16 +6,15 @@ pkgdesc="The Apache Portable Runtime Utility Library"
url="http://apr.apache.org/"
arch="all"
license="Apache-2.0"
-depends=
-subpackages="$pkgname-dev $pkgname-dbm_db $pkgname-dbd_pgsql
- $pkgname-dbd_sqlite3 $pkgname-ldap"
+depends=""
depends_dev="db-dev expat-dev openldap-dev openssl-dev postgresql-dev
sqlite-dev"
makedepends="$depends_dev apr-dev bash chrpath openssl"
+subpackages="$pkgname-dev $pkgname-dbm_db $pkgname-dbd_pgsql
+ $pkgname-dbd_sqlite3 $pkgname-ldap"
source="http://www.apache.org/dist/apr/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,13 +32,11 @@ build() {
}
check() {
- cd "$builddir"
# testxlate fails because UTF-7 is unsupported
make check || return 0
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/*.exp
chrpath -d "$pkgdir"/usr/lib/*.so.*
@@ -48,7 +45,7 @@ package() {
_mv_mod() {
pkgdesc="The Apache Portable Runtime Utility Library - $2 driver"
depends=
- local _moddir="usr/lib/apr-util-1"
+ _moddir="usr/lib/apr-util-1"
mkdir -p "$subpkgdir"/$_moddir
mv "$pkgdir"/$_moddir/apr_$1*.so "$subpkgdir"/$_moddir/
}