summaryrefslogtreecommitdiff
path: root/user/aspell-dict-af/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
commitc999dc9826ec3ac419865778b19f4ba2e710a50f (patch)
tree928d6c9fd778122d915bccfe71c9e95164523bdc /user/aspell-dict-af/APKBUILD
parentf64e3c9d8907eb4ee3165975ceb1267d4eb40c5c (diff)
parente8ea961cf71d87ff11329a1e2d56b9f7626c1f2c (diff)
downloadpackages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.gz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.bz2
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.xz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.zip
Merge branch 'aspell' into 'master'
Fix aspell package, add all (official) aspell dictionaries See merge request !128
Diffstat (limited to 'user/aspell-dict-af/APKBUILD')
-rw-r--r--user/aspell-dict-af/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/aspell-dict-af/APKBUILD b/user/aspell-dict-af/APKBUILD
new file mode 100644
index 000000000..b06ffd33f
--- /dev/null
+++ b/user/aspell-dict-af/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=aspell-dict-af
+pkgver=0.50.0
+_pkgver=${pkgver%.*}-${pkgver#*.*.}
+pkgrel=0
+pkgdesc="Afrikaans dictionaries for aspell"
+url="http://aspell.net"
+arch="noarch"
+license="LGPL-2.1-only"
+options="!check" # no tests
+depends="aspell"
+makedepends="debianutils-which"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/af/aspell-af-$_pkgver.tar.bz2"
+builddir="$srcdir/aspell-af-$_pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --vars DESTDIR="$pkgdir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8ca7b892745bebe5dfda1319141c5efc53fbad1444066d585cc2d6479c51c85c31307a6977a0647b0c4add4a5b7baa9adb370996e25db4e1c98f1c10991fd649 aspell-af-0.50-0.tar.bz2"