summaryrefslogtreecommitdiff
path: root/user/aspell-dict-pl/APKBUILD
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-12-17 05:59:11 -0600
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-12-17 05:59:11 -0600
commitf38cf8011e38ebc48b8f9002efef228a210e4c43 (patch)
treeae0de2827192a65d6baf56b6ad0fe8c2f58ae591 /user/aspell-dict-pl/APKBUILD
parent993391990c2e08985c84957ca485de7766adf051 (diff)
downloadpackages-f38cf8011e38ebc48b8f9002efef228a210e4c43.tar.gz
packages-f38cf8011e38ebc48b8f9002efef228a210e4c43.tar.bz2
packages-f38cf8011e38ebc48b8f9002efef228a210e4c43.tar.xz
packages-f38cf8011e38ebc48b8f9002efef228a210e4c43.zip
user/aspell-dict-pl: new package
Diffstat (limited to 'user/aspell-dict-pl/APKBUILD')
-rw-r--r--user/aspell-dict-pl/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/aspell-dict-pl/APKBUILD b/user/aspell-dict-pl/APKBUILD
new file mode 100644
index 000000000..f57d8bec4
--- /dev/null
+++ b/user/aspell-dict-pl/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=aspell-dict-pl
+pkgver=6.0.20061121.0
+_pkgver=${pkgver%.*.*}_${pkgver#*.*.}
+_pkgver=${_pkgver%.*}-${pkgver#*.*.*.}
+pkgrel=0
+pkgdesc="Polish dictionaries for aspell"
+url="http://aspell.net"
+arch="noarch"
+options="!check" # no tests
+license="GPL-2.0-only"
+depends="aspell"
+makedepends="debianutils-which"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/pl/aspell6-pl-$_pkgver.tar.bz2"
+builddir="$srcdir/aspell6-pl-$_pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --vars DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="424842fd3b4b2a00445590527a64393044e067b32ab973d07d90d5f35cd146ea7ae88c4f4b473a68759aa0d27a5c0fcd75b9ef0bb8ceb76e731eafd3aefc81c6 aspell6-pl-6.0_20061121-0.tar.bz2"