summaryrefslogtreecommitdiff
path: root/user/aspell-dict-vi/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
commitc999dc9826ec3ac419865778b19f4ba2e710a50f (patch)
tree928d6c9fd778122d915bccfe71c9e95164523bdc /user/aspell-dict-vi/APKBUILD
parentf64e3c9d8907eb4ee3165975ceb1267d4eb40c5c (diff)
parente8ea961cf71d87ff11329a1e2d56b9f7626c1f2c (diff)
downloadpackages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.gz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.bz2
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.xz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.zip
Merge branch 'aspell' into 'master'
Fix aspell package, add all (official) aspell dictionaries See merge request !128
Diffstat (limited to 'user/aspell-dict-vi/APKBUILD')
-rw-r--r--user/aspell-dict-vi/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/aspell-dict-vi/APKBUILD b/user/aspell-dict-vi/APKBUILD
new file mode 100644
index 000000000..12a23ae79
--- /dev/null
+++ b/user/aspell-dict-vi/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=aspell-dict-vi
+pkgver=0.01.1.1
+_pkgver=${pkgver%.*}-${pkgver#*.*.*.}
+pkgrel=0
+pkgdesc="Vietnamese dictionaries for aspell"
+url="http://aspell.net"
+arch="noarch"
+options="!check" # no tests
+license="GPL-2.0-only"
+depends="aspell"
+makedepends="debianutils-which"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/vi/aspell6-vi-$_pkgver.tar.bz2"
+builddir="$srcdir/aspell6-vi-$_pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --vars DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="d6b0a85ea3edf3193327f6df1b9c24947663fe711f060f10122e2c60aea2717d70277fd516fa685d9886c725baeebfc72d3f33e240ee8d182be669da716bb5c5 aspell6-vi-0.01.1-1.tar.bz2"