summaryrefslogtreecommitdiff
path: root/user/atril/APKBUILD
diff options
context:
space:
mode:
authorSheila Aman <sheila@vulpine.house>2021-07-21 13:55:31 +0000
committerSheila Aman <sheila@vulpine.house>2021-07-21 13:55:49 +0000
commit12ae64861055306f2645c6500379378895b1c0b2 (patch)
treeb2080f8e07cc733cd4faad2451341a1f71b18fca /user/atril/APKBUILD
parent49e7734c7b0c843091c40833484810f0a9866394 (diff)
downloadpackages-12ae64861055306f2645c6500379378895b1c0b2.tar.gz
packages-12ae64861055306f2645c6500379378895b1c0b2.tar.bz2
packages-12ae64861055306f2645c6500379378895b1c0b2.tar.xz
packages-12ae64861055306f2645c6500379378895b1c0b2.zip
user/atril: upgrade to 1.24.1
Diffstat (limited to 'user/atril/APKBUILD')
-rw-r--r--user/atril/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/user/atril/APKBUILD b/user/atril/APKBUILD
index 35640633f..a66295273 100644
--- a/user/atril/APKBUILD
+++ b/user/atril/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=atril
-pkgver=1.22.3
+pkgver=1.24.1
pkgrel=0
pkgdesc="Document viewer for the MATE desktop environment"
url="https://mate-desktop.org"
@@ -9,12 +9,17 @@ arch="all"
options="!check" # testsuite requires X and py3-dogtail
license="GPL-2.0+ AND Afmparse AND Info-ZIP AND libtiff AND LGPL-2.0+ AND MIT AND LGPL-2.1+"
depends=""
+_regendepends="autoconf autoconf-archive-dev automake gtk-doc itstool mate-common
+ mate-common-dev yelp-tools yelp-tools-dev"
makedepends="caja-dev djvulibre-dev gobject-introspection-dev gtk+3.0-dev
- intltool itstool libgxps-dev libsecret-dev libsm-dev libspectre-dev
- libxml2-dev libxml2-utils poppler-dev python3 tiff-dev"
+ intltool libgxps-dev libsecret-dev libsm-dev libspectre-dev
+ libxml2-dev libxml2-utils poppler-dev python3 tiff-dev
+ wayland-protocols $_regendepends"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pub.mate-desktop.org/releases/1.22/atril-$pkgver.tar.xz
- CVE-2019-11459.patch"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/atril-$pkgver.tar.xz
+ fix-autogen.patch
+ optional-synctex.patch
+ "
# secfixes:
# 1.22.1-r1:
@@ -23,7 +28,8 @@ source="https://pub.mate-desktop.org/releases/1.22/atril-$pkgver.tar.xz
# - CVE-2019-11459
build() {
- ./configure \
+ ./autogen.sh \
+ --disable-maintainer-mode \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -33,7 +39,8 @@ build() {
--enable-introspection \
--enable-pixbuf \
--enable-comics \
- --enable-xps
+ --enable-xps \
+ --disable-synctex
make
}
@@ -45,5 +52,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f4a83702818e1fb32279c67f1727c01480d27fe756f3fc0ff9dcd42584ce74ce10ac7ee81c0149f3756b6eb08f2a011ede28706ab54ff16a51c544a1af3b103f atril-1.22.3.tar.xz
-ba4ec4b0e10d87f44f189a16cfe2419906e3776edc9bc14f7da9356a8953683e3f7efc441691df131497b08b892d3b291aab416310f259ee6bc0706cc4f02880 CVE-2019-11459.patch"
+sha512sums="94a55e7699bdfc9368e20986664bd411c12f50f466874ebf20210df3de6ddb499866b505e157c56b58a8065aad2c24284b96afa8c547a6cd259eef413096a91a atril-1.24.1.tar.xz
+91d46a43267c5668c6831c81a1ee213564f833e64d8297c372b9ddc5037ae2d13594829a25b2a8086c46aa85068ad7a5024db4f5853ab009d5cbca9013fc9cc9 fix-autogen.patch
+cb4493eca4e0bc1bd4a9bdd4540033aad3318023f6101f5548c14c7c7134ce6a4618849df44573af39af7d561ebca4b9b549668e81c50c7432a525db7d0f620b optional-synctex.patch"