summaryrefslogtreecommitdiff
path: root/user/ayatana-ido/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-06 21:39:29 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-06 21:39:29 +0000
commitacb432c778550f3eae0598504ad8295d2f228889 (patch)
tree9985b1b8945213626073d04aa89aeb05b7694efc /user/ayatana-ido/APKBUILD
parent8f8a0eb8788f35c1ca5db3730bcc10535934c05e (diff)
downloadpackages-acb432c778550f3eae0598504ad8295d2f228889.tar.gz
packages-acb432c778550f3eae0598504ad8295d2f228889.tar.bz2
packages-acb432c778550f3eae0598504ad8295d2f228889.tar.xz
packages-acb432c778550f3eae0598504ad8295d2f228889.zip
user/ayatana-ido: Fix build with newer GLib
Upstream-URL: https://github.com/AyatanaIndicators/ayatana-ido/commit/0ab4079b2
Diffstat (limited to 'user/ayatana-ido/APKBUILD')
-rw-r--r--user/ayatana-ido/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/user/ayatana-ido/APKBUILD b/user/ayatana-ido/APKBUILD
index dbc939270..fd0aaf9db 100644
--- a/user/ayatana-ido/APKBUILD
+++ b/user/ayatana-ido/APKBUILD
@@ -2,26 +2,26 @@
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=ayatana-ido
pkgver=0.4.4
-pkgrel=0
+pkgrel=1
pkgdesc="Indicator display object library for the Gnome desktop environment"
url="https://ayatanaindicators.github.io/"
arch="all"
license="GPL-3.0-only AND (LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0+"
depends=""
makedepends="glib-dev gobject-introspection-dev gtest-dev gtk+3.0-dev
- mate-common-dev vala-dev xorg-gtest-dev"
+ mate-common-dev vala-dev xorg-gtest-dev autoconf automake"
subpackages="$pkgname-dev"
source="ayatana-ido-$pkgver.tar.gz::https://github.com/AyatanaIndicators/ayatana-ido/archive/$pkgver.tar.gz
- gtk-doc-fix.patch"
+ gtk-doc-fix.patch
+ remove-private.patch
+ "
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,14 +33,13 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" make install
}
sha512sums="ef04b0b6c959d209e88b1de322ac64ea33fdd043a73980bf3b043380603b6a448ea7bf43ba8e2750e1a0a9bef704a7099f7ae9b92a97d3ce0be2e9f48ba16703 ayatana-ido-0.4.4.tar.gz
-92ddc4f09c5ed7800357a76e2276c07db682408f259e22d6511696df032d6712ecd295d0775db36ad6ace5d3f352ce7d59cd9f1b24e899b7accaf680c0e4488d gtk-doc-fix.patch"
+92ddc4f09c5ed7800357a76e2276c07db682408f259e22d6511696df032d6712ecd295d0775db36ad6ace5d3f352ce7d59cd9f1b24e899b7accaf680c0e4488d gtk-doc-fix.patch
+a28c4cbfb5f386a9ee42ec50011bce603191b901760e6f9799a58b9ff2b223d03c15df00bd6fab6e13b9b9d5b70ecedef245665ebf4e240df1f1321e658b38fa remove-private.patch"