summaryrefslogtreecommitdiff
path: root/user/baloo/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-05 04:52:06 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-05 04:52:06 -0500
commit73574018d06be3563335eeea720b50ec87994430 (patch)
tree6918aae8306d4ecf63cb3dc341f44801025e9cc5 /user/baloo/APKBUILD
parenta10919f2dac4754a70ff193ad524eee555d65e17 (diff)
downloadpackages-73574018d06be3563335eeea720b50ec87994430.tar.gz
packages-73574018d06be3563335eeea720b50ec87994430.tar.bz2
packages-73574018d06be3563335eeea720b50ec87994430.tar.xz
packages-73574018d06be3563335eeea720b50ec87994430.zip
user/baloo: new package
Diffstat (limited to 'user/baloo/APKBUILD')
-rw-r--r--user/baloo/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/user/baloo/APKBUILD b/user/baloo/APKBUILD
new file mode 100644
index 000000000..e9d7cfbc6
--- /dev/null
+++ b/user/baloo/APKBUILD
@@ -0,0 +1,62 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=baloo
+pkgver=5.38.0
+pkgrel=0
+pkgdesc="Semantic desktop search framework"
+url="https://www.kde.org/"
+arch="all"
+license="LGPL-2.1"
+# Test #4 in the suite, bin/querytest:
+# Test cleanup method is not run after testTermEqual.
+# This leaves a `db` handle stale, which is using the single-reader-per-thread
+# pthread_key that lmdb provides.
+# This causes the next test, testTermStartsWith, to fail to acquire a reader
+# transaction because the previous transaction was not committed or aborted.
+# Since the test does not check for a transaction failure and blindly uses the
+# transaction object returned, it attempts to access 0xc (accessing a member of
+# the returned nullptr), and segfaults.
+# Three other tests in the suite fail in the same way.
+# This may be a bug in libQtTest, or in musl. I have not debugged further.
+# This has already taken up two days of my time and I just want to ship Plasma
+options="!check"
+depends=""
+depends_dev="qt5-qtbase-dev kcoreaddons-dev kconfig-dev kdbusaddons-dev lmdb-dev
+ ki18n-dev kidletime-dev solid-dev kfilemetadata-dev kcrash-dev kio-dev"
+makedepends="$depends_dev cmake extra-cmake-modules python3 gettext-dev doxygen
+ graphviz qt5-qttools-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://download.kde.org/static/frameworks/5.38/baloo-$pkgver.tar.xz
+ initialise-variable.patch"
+builddir="$srcdir/baloo-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="39dd317c9a9b2b3ec038ad8785e9c70ef7d16ac43a36f34a12b55c7c2a505001e33db467ddad0ea2921c14a0dcc7d3bec4564b14c699101839a46624637487f4 baloo-5.38.0.tar.xz
+5622f1eb7a692c0ebd5d904b421612292375d3ea3f4ffdc4624fa8e2dc4a5fe56e5636f11a388224642be03c8fc28a678cffb9b167eb3de48ff4ae2979e6435e initialise-variable.patch"