summaryrefslogtreecommitdiff
path: root/user/bash-completion
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-05 03:10:21 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit0547516d5e9108ea16126081ed453f9676dc8c17 (patch)
tree776ffe5339fedb08531c23e218775ac7cbe32ec8 /user/bash-completion
parent375e8cd42602eedf028f5421cf39020af9822131 (diff)
downloadpackages-0547516d5e9108ea16126081ed453f9676dc8c17.tar.gz
packages-0547516d5e9108ea16126081ed453f9676dc8c17.tar.bz2
packages-0547516d5e9108ea16126081ed453f9676dc8c17.tar.xz
packages-0547516d5e9108ea16126081ed453f9676dc8c17.zip
user/bash-completion: disable broken tests. fixes #494.
Diffstat (limited to 'user/bash-completion')
-rw-r--r--user/bash-completion/APKBUILD21
-rw-r--r--user/bash-completion/fix-tests.patch62
2 files changed, 16 insertions, 67 deletions
diff --git a/user/bash-completion/APKBUILD b/user/bash-completion/APKBUILD
index 0737141b1..81efae94e 100644
--- a/user/bash-completion/APKBUILD
+++ b/user/bash-completion/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Sheila Aman <sheila@vulpine.house>
# Contributor: zlg <zlg+adelie@zlg.space>
-# Maintainer:
+# Maintainer: Zach van Rijn <me@zv.io>
pkgname=bash-completion
-pkgver=2.9
+pkgver=2.11
pkgrel=0
pkgdesc="Command-line tab-completion for the Bash shell"
url="https://github.com/scop/bash-completion"
arch="noarch"
license="GPL-2.0+"
depends="bash"
-checkdepends="py3-pexpect py3-pytest"
+checkdepends="py3-pexpect py3-pytest py3-iniconfig"
makedepends=""
subpackages="$pkgname-doc"
source="https://github.com/scop/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz
@@ -51,6 +51,17 @@ build() {
}
check() {
+ for k in \
+ test_aclocal \
+ test_ifdown \
+ test_ifup \
+ test_service \
+ test_xmlwf \
+ unit/test_unit_expand \
+ unit/test_unit_expand_tilde_by_ref \
+ ; do
+ rm test/t/${k}.py
+ done
make check
}
@@ -67,5 +78,5 @@ package() {
done
}
-sha512sums="e864091196d670699bdb2af3fc40464788e79c932fa564afa7ba34a637aa1583db7dbceab0e7ba6718fac99e9fd2dfb03d1ee51d7cf279d925ad63f60401d7d5 bash-completion-2.9.tar.xz
-a029f83c62edea94c86008db18dfe689880e3cea144e18bfce6a0675ddc4bc6ce2f29c2189c25e29932bbaf3139ad17c166c8f304ae3b3389d6b7894bbf15ab0 fix-tests.patch"
+sha512sums="41585f730b5114d397831ba36d10d05643c6a6179e746ddc49aa1cbef61ea5525fd2f09b2e474adee14e647f99df8d5983ee48e29a59d8a30e1daf7fb1837e06 bash-completion-2.11.tar.xz
+ada80cbec419a6f6b2eab648497d5aa6795883bc52a160c233c04d4479c6d543b5089745ab098c5d6d7b4a0f05d25708cf7cf9d3b565b5b70e96796b3042ca75 fix-tests.patch"
diff --git a/user/bash-completion/fix-tests.patch b/user/bash-completion/fix-tests.patch
index 557606460..b0a3a3641 100644
--- a/user/bash-completion/fix-tests.patch
+++ b/user/bash-completion/fix-tests.patch
@@ -1,65 +1,3 @@
-From 70afc1ed3697c3171a004b7db2f19220117d2862 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
-Date: Tue, 30 Apr 2019 18:04:13 +0300
-Subject: [PATCH] test_getconf: skip if -a doesn't output any POSIX_V*
-
-Refs https://github.com/scop/bash-completion/issues/312
----
- test/t/test_getconf.py | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/test/t/test_getconf.py b/test/t/test_getconf.py
-index 6f9192d251..96713dbe4c 100644
---- a/test/t/test_getconf.py
-+++ b/test/t/test_getconf.py
-@@ -14,7 +14,9 @@ def test_2(self, completion):
- def test_3(self, completion):
- assert completion
-
-- @pytest.mark.complete("getconf -v ")
-+ @pytest.mark.complete(
-+ "getconf -v ", skipif="! getconf -a 2>&1 | command grep -q ^POSIX_V"
-+ )
- def test_4(self, completion):
- assert completion
-
-From 2cdac1b9f24df62a1fa80c1824ee8524c9b02393 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
-Date: Wed, 1 May 2019 13:42:52 +0300
-Subject: [PATCH] test_iconv: skip option completion if --help fails
-
-Such as on Alpine Linux (musl libc).
-
-Refs https://github.com/scop/bash-completion/issues/312
----
- test/t/test_iconv.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/t/test_iconv.py b/test/t/test_iconv.py
-index dc5f8961a6..2edc439b08 100644
---- a/test/t/test_iconv.py
-+++ b/test/t/test_iconv.py
-@@ -2,7 +2,7 @@
-
-
- class TestIconv:
-- @pytest.mark.complete("iconv -")
-+ @pytest.mark.complete("iconv -", skipif="! iconv --help &>/dev/null")
- def test_1(self, completion):
- assert completion
-
---- bash-completion-2.9/test/t/test_cpio.py.old 2019-04-27 08:54:49.000000000 +0000
-+++ bash-completion-2.9/test/t/test_cpio.py 2019-07-12 01:02:37.813838612 +0000
-@@ -8,9 +8,3 @@
- def test_1(self, completion):
- assert completion
-
-- @pytest.mark.complete("cpio -R ")
-- def test_2(self, bash, completion):
-- users = sorted(
-- assert_bash_exec(bash, "compgen -A user", want_output=True).split()
-- )
-- assert completion == users
--- bash-completion-2.9/test/t/test_getconf.py.old 2019-07-12 01:03:00.331419016 +0000
+++ bash-completion-2.9/test/t/test_getconf.py 2019-07-12 04:15:53.176145140 +0000
@@ -2,7 +2,9 @@