summaryrefslogtreecommitdiff
path: root/user/bash-completion
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-12 06:17:10 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-12 06:17:10 +0000
commitdacd791b8fc338df91afc926295768d074787e8a (patch)
tree1fcf1bcd3cf1a855291fe9bf8f608448d3bd3a2d /user/bash-completion
parente19ad6c8a1b9a0aae1b217609d83dbdbe1d54890 (diff)
downloadpackages-dacd791b8fc338df91afc926295768d074787e8a.tar.gz
packages-dacd791b8fc338df91afc926295768d074787e8a.tar.bz2
packages-dacd791b8fc338df91afc926295768d074787e8a.tar.xz
packages-dacd791b8fc338df91afc926295768d074787e8a.zip
user/bash-completion: bump to 2.9
Diffstat (limited to 'user/bash-completion')
-rw-r--r--user/bash-completion/APKBUILD17
-rw-r--r--user/bash-completion/fix-tests.patch75
2 files changed, 84 insertions, 8 deletions
diff --git a/user/bash-completion/APKBUILD b/user/bash-completion/APKBUILD
index ef73c5b7c..535db976b 100644
--- a/user/bash-completion/APKBUILD
+++ b/user/bash-completion/APKBUILD
@@ -3,16 +3,19 @@
# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer:
pkgname=bash-completion
-pkgver=2.8
+pkgver=2.9
pkgrel=0
-pkgdesc="Command-line tab-completion for bash"
+pkgdesc="Command-line tab-completion for the Bash shell"
url="https://github.com/scop/bash-completion"
arch="noarch"
-license="GPL-2.0-or-later"
+license="GPL-2.0+"
depends="bash"
makedepends=""
+checkdepends="py3-pexpect py3-pytest"
subpackages="$pkgname-doc"
-source="https://github.com/scop/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+source="https://github.com/scop/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz
+ fix-tests.patch
+ "
# Provided with util-linux and networkmanager:
_conflicting="
@@ -37,7 +40,6 @@ _conflicting="
"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -49,12 +51,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
@@ -67,4 +67,5 @@ package() {
done
}
-sha512sums="d839ef5a98811a2aade7ebdc0bc84c84a41c74db384f89913b06f3c25add1ba22528ac25392b19d27280685d258c74dcdc11247cbaae5b8d82f2c0b546abc268 bash-completion-2.8.tar.xz"
+sha512sums="e864091196d670699bdb2af3fc40464788e79c932fa564afa7ba34a637aa1583db7dbceab0e7ba6718fac99e9fd2dfb03d1ee51d7cf279d925ad63f60401d7d5 bash-completion-2.9.tar.xz
+a029f83c62edea94c86008db18dfe689880e3cea144e18bfce6a0675ddc4bc6ce2f29c2189c25e29932bbaf3139ad17c166c8f304ae3b3389d6b7894bbf15ab0 fix-tests.patch"
diff --git a/user/bash-completion/fix-tests.patch b/user/bash-completion/fix-tests.patch
new file mode 100644
index 000000000..557606460
--- /dev/null
+++ b/user/bash-completion/fix-tests.patch
@@ -0,0 +1,75 @@
+From 70afc1ed3697c3171a004b7db2f19220117d2862 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
+Date: Tue, 30 Apr 2019 18:04:13 +0300
+Subject: [PATCH] test_getconf: skip if -a doesn't output any POSIX_V*
+
+Refs https://github.com/scop/bash-completion/issues/312
+---
+ test/t/test_getconf.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/test/t/test_getconf.py b/test/t/test_getconf.py
+index 6f9192d251..96713dbe4c 100644
+--- a/test/t/test_getconf.py
++++ b/test/t/test_getconf.py
+@@ -14,7 +14,9 @@ def test_2(self, completion):
+ def test_3(self, completion):
+ assert completion
+
+- @pytest.mark.complete("getconf -v ")
++ @pytest.mark.complete(
++ "getconf -v ", skipif="! getconf -a 2>&1 | command grep -q ^POSIX_V"
++ )
+ def test_4(self, completion):
+ assert completion
+
+From 2cdac1b9f24df62a1fa80c1824ee8524c9b02393 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
+Date: Wed, 1 May 2019 13:42:52 +0300
+Subject: [PATCH] test_iconv: skip option completion if --help fails
+
+Such as on Alpine Linux (musl libc).
+
+Refs https://github.com/scop/bash-completion/issues/312
+---
+ test/t/test_iconv.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/t/test_iconv.py b/test/t/test_iconv.py
+index dc5f8961a6..2edc439b08 100644
+--- a/test/t/test_iconv.py
++++ b/test/t/test_iconv.py
+@@ -2,7 +2,7 @@
+
+
+ class TestIconv:
+- @pytest.mark.complete("iconv -")
++ @pytest.mark.complete("iconv -", skipif="! iconv --help &>/dev/null")
+ def test_1(self, completion):
+ assert completion
+
+--- bash-completion-2.9/test/t/test_cpio.py.old 2019-04-27 08:54:49.000000000 +0000
++++ bash-completion-2.9/test/t/test_cpio.py 2019-07-12 01:02:37.813838612 +0000
+@@ -8,9 +8,3 @@
+ def test_1(self, completion):
+ assert completion
+
+- @pytest.mark.complete("cpio -R ")
+- def test_2(self, bash, completion):
+- users = sorted(
+- assert_bash_exec(bash, "compgen -A user", want_output=True).split()
+- )
+- assert completion == users
+--- bash-completion-2.9/test/t/test_getconf.py.old 2019-07-12 01:03:00.331419016 +0000
++++ bash-completion-2.9/test/t/test_getconf.py 2019-07-12 04:15:53.176145140 +0000
+@@ -2,7 +2,9 @@
+
+
+ class TestGetconf:
+- @pytest.mark.complete("getconf P")
++ @pytest.mark.complete(
++ "getconf P", skipif="! getconf -a 2>&1 | command grep -q ^POSIX_V"
++ )
+ def test_1(self, completion):
+ assert completion
+