summaryrefslogtreecommitdiff
path: root/user/calligra
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-14 18:54:59 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-14 18:54:59 +0000
commit24d6d9273c29fc00b392ac2fa74ff51b8d06f073 (patch)
tree66aedd88134a478c2ac81c3145f34e98a55e03e8 /user/calligra
parentce4b7b54ce42b8eec74967d260086dd5542a22fa (diff)
downloadpackages-24d6d9273c29fc00b392ac2fa74ff51b8d06f073.tar.gz
packages-24d6d9273c29fc00b392ac2fa74ff51b8d06f073.tar.bz2
packages-24d6d9273c29fc00b392ac2fa74ff51b8d06f073.tar.xz
packages-24d6d9273c29fc00b392ac2fa74ff51b8d06f073.zip
user/calligra: Fix build with Poppler 0.72 and 0.73+
Diffstat (limited to 'user/calligra')
-rw-r--r--user/calligra/APKBUILD4
-rw-r--r--user/calligra/poppler-73.patch45
2 files changed, 48 insertions, 1 deletions
diff --git a/user/calligra/APKBUILD b/user/calligra/APKBUILD
index 787ba8ba8..a17bf9711 100644
--- a/user/calligra/APKBUILD
+++ b/user/calligra/APKBUILD
@@ -34,6 +34,7 @@ source="https://download.kde.org/stable/calligra/$pkgver/calligra-$pkgver.tar.xz
poppler2.patch
poppler3.patch
poppler4.patch
+ poppler-73.patch
"
prepare() {
@@ -83,4 +84,5 @@ b03d2f33a0233638be06b4219328404eac4a77c508619c4037b3b53556b257fc4888cd690bb37555
960614eb2d367443810cc356d004d43867a4fa4085b054ffd1522b94ef09e9338e723117c91148383d33d54104729750a199ab1b75569aaa7164a908afd3cd4c poppler.patch
53296af0b1ad39c523bc93a0040f1316dfb52e2077d277a83841a741c5cb48d81efb1f6328b2af2c8f1dc92db12c4d771a9a65028498d7802b2c30dd702b9455 poppler2.patch
a22b78d9664284ee5de7a4299907ec37a7835cb6ae3af8e7c1ee0202cea8c1e544fbad7395e56115fb5fe13ec06aeff22e381431e20c6c151c93003cf8a45446 poppler3.patch
-df0e592f8c314581b1811776f8aa1c3dd32f05f966f23ef4dd023c41dad759aea8b674b32e2bd7bee36efe4ba0ce0bdd08f3fc30d10115330605d09d46883a28 poppler4.patch"
+df0e592f8c314581b1811776f8aa1c3dd32f05f966f23ef4dd023c41dad759aea8b674b32e2bd7bee36efe4ba0ce0bdd08f3fc30d10115330605d09d46883a28 poppler4.patch
+8440f1c36aba9cb54efa36fae73d605f57e78d055225c776791b14554d6be6f081f8cdc3fa65fb9c0b600a3b030d7776b45f631b9bc00d495ab16bfc35bd66f4 poppler-73.patch"
diff --git a/user/calligra/poppler-73.patch b/user/calligra/poppler-73.patch
new file mode 100644
index 000000000..aa71e20b4
--- /dev/null
+++ b/user/calligra/poppler-73.patch
@@ -0,0 +1,45 @@
+--- calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp.old 2019-01-14 18:40:55.580000000 +0000
++++ calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp 2019-01-14 18:53:05.000000000 +0000
+@@ -402,7 +402,7 @@
+
+ QString str;
+
+- const char * p = s->getCString();
++ const char * p = s->c_str();
+ int len = s->getLength();
+ CharCode code;
+ Unicode *u = nullptr;
+@@ -451,11 +451,11 @@
+ *d->body << " y=\"" << y << "px\"";
+
+ if (font && font->getFamily()) {
+- *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->getCString()) << "\"";
+- //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->getCString() );
++ *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->c_str()) << "\"";
++ //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->c_str() );
+ } else if (font && font->getName()) {
+- *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->getCString()) << "\"";
+- //debugPdf << "font name:" << QString::fromLatin1( font->getName()->getCString() );
++ *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->c_str()) << "\"";
++ //debugPdf << "font name:" << QString::fromLatin1( font->getName()->c_str() );
+ }
+ *d->body << " font-size=\"" << qMax(state->getFontSize(), state->getTransformedFontSize()) << "px\"";
+
+@@ -488,7 +488,7 @@
+ if (maskColors) {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+
+ for (int x = 0; x < width; x++) {
+@@ -507,7 +507,7 @@
+ } else {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+ }
+