summaryrefslogtreecommitdiff
path: root/user/certbot
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:59:07 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:59:07 +0000
commit1d5bbfe40b832dccae70c9c3570e4e165f15d8ad (patch)
treeed952e2b60755e98a21270db253e7e0af6642510 /user/certbot
parentc999dc9826ec3ac419865778b19f4ba2e710a50f (diff)
parente4a73a3d14a57d6ba40fccb850ee3b27a4e9f962 (diff)
downloadpackages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.tar.gz
packages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.tar.bz2
packages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.tar.xz
packages-1d5bbfe40b832dccae70c9c3570e4e165f15d8ad.zip
Merge branch 'add-certbot' into 'master'
Add certbot and dependencies This branch brings Certbot support to Adélie Linux. Tests were supported in packages where it was reasonable, avoiding long dependency chains (AKA rabbit holes). Some highlights: * Effort was made to ensure everything worked with Python 3; * Python 2.x-only libraries were worked around or removed from dependencies where possible; * Packages were made to defer to system files (such as zoneinfo and ca-cert files) where possible; * Packages were added in dependency-stack order; all dependencies for a package should've been added before the higher level package. There are a lot of packages here, so there may be some edge cases that the runtime testing of certbot did not catch. I was able to successfully receive a brand new wildcard + bare domain (SAN) Let's Encrypt certificate and serve a website over the network to a machine running Firefox 63.0.1. **EDIT 2018-11-28:** I've gone through each APKBUILD and addressed the common pitfalls I noticed in addition to the comments already issued. Packages were version-bumped where possible. See merge request !113
Diffstat (limited to 'user/certbot')
-rw-r--r--user/certbot/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/certbot/APKBUILD b/user/certbot/APKBUILD
new file mode 100644
index 000000000..5c0ba42d9
--- /dev/null
+++ b/user/certbot/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=certbot
+pkgver=0.28.0
+pkgrel=0
+pkgdesc="The EFF's reference ACME client"
+url="https://certbot.eff.org/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-acme py3-configargparse py3-mock py3-configobj py3-cryptography
+ py3-parsedatetime py3-rfc3339 py3-tz py3-zope-component py3-zope-interface
+ coverage"
+# define acme deps here and add them to makedepends
+# so they get pulled in when bootstrapping.
+_depends_acme="python3 py3-cryptography py3-josepy py3-mock py3-openssl py3-requests
+ py3-requests-toolbelt py3-rfc3339 py3-six py3-tz"
+makedepends="python3-dev $_depends_acme"
+subpackages="py3-acme:acme"
+source="certbot-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/v$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+acme() {
+ pkgdesc="ACME protocol implementation for Python"
+ depends="$_depends_acme"
+ cd "$builddir"/acme
+ python3 setup.py build
+ python3 setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="07c9bbad52acebc60e48d79619e4f12818d67c3b0f41ffa4fcd02098fb9da245e4006418f54c51c2e4bb9aaa01a21f7a083c9eb092f533e6676ed75ae8667a54 certbot-0.28.0.tar.gz"