summaryrefslogtreecommitdiff
path: root/user/clang/ppc-dirwatcher.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-12-05 02:23:19 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-12-05 02:23:19 +0000
commit1f70373be016b80505407f5b2f2d813b6d782694 (patch)
tree331cddf4323c2eb1c0e3beba47afbc32e7da71ad /user/clang/ppc-dirwatcher.patch
parent0ef3b184a5fe0c69b8b9b53e010362c07f09a2ac (diff)
downloadpackages-1f70373be016b80505407f5b2f2d813b6d782694.tar.gz
packages-1f70373be016b80505407f5b2f2d813b6d782694.tar.bz2
packages-1f70373be016b80505407f5b2f2d813b6d782694.tar.xz
packages-1f70373be016b80505407f5b2f2d813b6d782694.zip
user/clang: Disable tests on PowerPC
The Interpreter unit-test is already disabled on AIX, so it is likely ABI-related. The other Interpreter test needs R_PPC_REL24 to be implemented in the LLVM RuntimeDyld to work. The DirectoryWatcher tests are all broken for unknown reasons, but don't affect actual compilation so we just skip them for now. Fixes: #848
Diffstat (limited to 'user/clang/ppc-dirwatcher.patch')
-rw-r--r--user/clang/ppc-dirwatcher.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/user/clang/ppc-dirwatcher.patch b/user/clang/ppc-dirwatcher.patch
new file mode 100644
index 000000000..35587152f
--- /dev/null
+++ b/user/clang/ppc-dirwatcher.patch
@@ -0,0 +1,10 @@
+Doesn't work on PowerPC.
+
+--- clang-14.0.6.src/unittests/DirectoryWatcher/CMakeLists.txt.old 2022-06-22 16:46:24.000000000 +0000
++++ clang-14.0.6.src/unittests/DirectoryWatcher/CMakeLists.txt 2022-12-05 01:14:23.863133395 +0000
+@@ -1,4 +1,4 @@
+-if(APPLE OR CMAKE_SYSTEM_NAME MATCHES "Linux" OR CMAKE_SYSTEM_NAME STREQUAL Windows)
++if(APPLE OR (CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT (CMAKE_SYSTEM_PROCESSOR STREQUAL "ppc")) OR CMAKE_SYSTEM_NAME STREQUAL Windows)
+
+ set(LLVM_LINK_COMPONENTS
+ Support