summaryrefslogtreecommitdiff
path: root/user/clucene
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-09-04 11:19:04 -0400
committerMax Rees <maxcrees@me.com>2018-09-04 11:19:04 -0400
commit22449e780e90c4f1503fceb45b787637d82816e4 (patch)
tree213e3507a0703bf3595bcd514ffc048342124e27 /user/clucene
parent859e0988612b06174e8389369df1c7de8f7a65b3 (diff)
downloadpackages-22449e780e90c4f1503fceb45b787637d82816e4.tar.gz
packages-22449e780e90c4f1503fceb45b787637d82816e4.tar.bz2
packages-22449e780e90c4f1503fceb45b787637d82816e4.tar.xz
packages-22449e780e90c4f1503fceb45b787637d82816e4.zip
user/clucene: tell check to use $builddir/tmp instead of tmp
If we use /tmp (the default), successive runs of check will usually fail because /tmp is not cleared on each run, and clucene is not smart enough to delete its test files on its own, so a whole bunch of tests will fail. Instead, tell it to use $builddir/tmp, which we can safely clear each time we run check.
Diffstat (limited to 'user/clucene')
-rw-r--r--user/clucene/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/user/clucene/APKBUILD b/user/clucene/APKBUILD
index 90f7a8eb7..2c5e047e4 100644
--- a/user/clucene/APKBUILD
+++ b/user/clucene/APKBUILD
@@ -40,11 +40,19 @@ build() {
check() {
cd "$builddir"
+
+ # clucene is not smart enough to delete files between successive checks,
+ # so let's remove them for it. Otherwise, if check is run a second time
+ # without clearing the files beforehand, a lot of tests will fail.
+ rm -rf "$builddir/tmp"
+ mkdir "$builddir/tmp"
+
# Need to force cmake to update - some sort of race condition
touch CMakeCache.txt
make cl_test
+
cd bin
- ./cl_test
+ TMP="$builddir/tmp" ./cl_test
}
package() {