summaryrefslogtreecommitdiff
path: root/user/dev86/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2020-03-22 10:36:34 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2020-03-22 10:36:34 +0000
commit8f4e2366f08fd0ad6903d3bc4b149352ea0443f6 (patch)
treed20d55e3b5e9336405f5f1bba05c2c0fc4cd55fc /user/dev86/APKBUILD
parent7a8eb9c1a4a9c2f3e3a3228266bcba74ab298c23 (diff)
parent4c63cae23bf6fc07dfe85c0aa2b9b7701cf28933 (diff)
downloadpackages-8f4e2366f08fd0ad6903d3bc4b149352ea0443f6.tar.gz
packages-8f4e2366f08fd0ad6903d3bc4b149352ea0443f6.tar.bz2
packages-8f4e2366f08fd0ad6903d3bc4b149352ea0443f6.tar.xz
packages-8f4e2366f08fd0ad6903d3bc4b149352ea0443f6.zip
Merge branch 'lilo' into 'master'
Add the LILO bootloader See merge request adelie/packages!412
Diffstat (limited to 'user/dev86/APKBUILD')
-rw-r--r--user/dev86/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/dev86/APKBUILD b/user/dev86/APKBUILD
new file mode 100644
index 000000000..a17deec0f
--- /dev/null
+++ b/user/dev86/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=dev86
+pkgver=0.16.21
+pkgrel=0
+pkgdesc="Standalone 8086 assembler and linker"
+url="https://github.com/lkundrak/dev86/"
+arch="pmmx x86 x86_64"
+options="!check" # Just compiles stuff with bcc which we don't build
+license="GPL-2.0 AND LGPL-2.0"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lkundrak/dev86/archive/v$pkgver.tar.gz"
+
+build() {
+ make -j1 as ld \
+ GCCFLAG="$CFLAGS" \
+ NATIVE='-DA_OUT_INCL=\"../libc/include/a.out.h\"'
+}
+
+package() {
+ install -Dm755 as/as86 "$pkgdir"/usr/bin/as86
+ install -Dm755 ld/ld86 "$pkgdir"/usr/bin/ld86
+
+ install -Dm644 man/as86.1 "$pkgdir"/usr/share/man/man1/as86.1
+ install -Dm644 man/ld86.1 "$pkgdir"/usr/share/man/man1/ld86.1
+}
+
+sha512sums="e51d94cecc298f860c1dcbc225d5c77a18769eb7a51f888853ca3bdb3cc6596c07d67cd9b403f7d52155716eb1708396461dc596cd02728d762d0ed5e87d054f dev86-0.16.21.tar.gz"