summaryrefslogtreecommitdiff
path: root/user/ebook-tools
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/ebook-tools
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/ebook-tools')
-rw-r--r--user/ebook-tools/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/user/ebook-tools/APKBUILD b/user/ebook-tools/APKBUILD
index 6c33ad3d5..6eeeb3cdb 100644
--- a/user/ebook-tools/APKBUILD
+++ b/user/ebook-tools/APKBUILD
@@ -8,12 +8,11 @@ url="https://sourceforge.net/projects/ebook-tools/"
arch="all"
license="MIT"
depends="convertlit cmd:which"
-makedepends="libxml2-dev libzip-dev"
+makedepends="cmake libxml2-dev libzip-dev"
subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/ebook-tools/ebook-tools-$pkgver.tar.gz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -22,17 +21,15 @@ build() {
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}