summaryrefslogtreecommitdiff
path: root/user/faad2/fix-x86-lrintf.patch
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-10-24 21:05:56 +0000
committerZach van Rijn <me@zv.io>2023-10-25 00:43:43 +0000
commit87b7d4eaefb6ce8a65ba2e9654784dad1df8f03d (patch)
tree4509c017eaeb5088bc2423959de497228d4877c7 /user/faad2/fix-x86-lrintf.patch
parentcb27b0550d7accf80d339023979859aee676f4b0 (diff)
downloadpackages-87b7d4eaefb6ce8a65ba2e9654784dad1df8f03d.tar.gz
packages-87b7d4eaefb6ce8a65ba2e9654784dad1df8f03d.tar.bz2
packages-87b7d4eaefb6ce8a65ba2e9654784dad1df8f03d.tar.xz
packages-87b7d4eaefb6ce8a65ba2e9654784dad1df8f03d.zip
user/faad2: add patch for x86. fixes #1095.
Additionally, ensure shared libraries are versioned. This fixes a regression from the autotools-based era that was not carried into the CMake era.
Diffstat (limited to 'user/faad2/fix-x86-lrintf.patch')
-rw-r--r--user/faad2/fix-x86-lrintf.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/user/faad2/fix-x86-lrintf.patch b/user/faad2/fix-x86-lrintf.patch
new file mode 100644
index 000000000..b0038b756
--- /dev/null
+++ b/user/faad2/fix-x86-lrintf.patch
@@ -0,0 +1,11 @@
+diff -ur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2023-10-24 21:00:08.223699531 +0000
++++ b/CMakeLists.txt 2023-10-24 21:00:30.200223679 +0000
+@@ -60,6 +60,7 @@
+ set(FAAD_DEFINES
+ APPLY_DRC
+ HAVE_INTTYPES_H=1
++ HAVE_LRINTF=1
+ HAVE_MEMCPY=1
+ HAVE_STRING_H=1
+ HAVE_STRINGS_H=1