summaryrefslogtreecommitdiff
path: root/user/farstream
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 10:25:26 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 10:25:26 +0000
commit549a5d5d1aaedf9c031884a4cbcf2b6a8df6d38e (patch)
tree3c8b5c5cfc10870f69107a9e8171f6eb9e1d00d4 /user/farstream
parentb0923a6c8e00a0e1f69322a9b6a46cb2c33f3c56 (diff)
downloadpackages-549a5d5d1aaedf9c031884a4cbcf2b6a8df6d38e.tar.gz
packages-549a5d5d1aaedf9c031884a4cbcf2b6a8df6d38e.tar.bz2
packages-549a5d5d1aaedf9c031884a4cbcf2b6a8df6d38e.tar.xz
packages-549a5d5d1aaedf9c031884a4cbcf2b6a8df6d38e.zip
user/farstream: Update to 0.2.9
Diffstat (limited to 'user/farstream')
-rw-r--r--user/farstream/APKBUILD12
-rw-r--r--user/farstream/make43.patch38
2 files changed, 46 insertions, 4 deletions
diff --git a/user/farstream/APKBUILD b/user/farstream/APKBUILD
index c5a6f422e..cba6a5fad 100644
--- a/user/farstream/APKBUILD
+++ b/user/farstream/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=farstream
-pkgver=0.2.8
+pkgver=0.2.9
pkgrel=0
pkgdesc="Audio/Video communications framework"
url="https://www.freedesktop.org/wiki/Software/Farstream/"
@@ -11,11 +11,14 @@ license="LGPL-2.1+"
depends="gst-plugins-base gst-plugins-good"
depends_dev="glib-dev"
makedepends="$depends_dev gobject-introspection-dev gstreamer-dev
- gst-plugins-base-dev libnice-dev"
+ gst-plugins-base-dev libnice-dev autoconf automake libtool cmd:which"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://freedesktop.org/software/farstream/releases/farstream/farstream-$pkgver.tar.gz"
+source="https://freedesktop.org/software/farstream/releases/farstream/farstream-$pkgver.tar.gz
+ make43.patch
+ "
build() {
+ ./autogen.sh --disable-gtk-doc
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,4 +38,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="7ec5c57f8778f4107cb628dbf411e38b726152cf78920127dff4423239ff7e4980b6b4f938abba2aa21ab984b1e3053e7e648611322a0ce94df0af576df99a7e farstream-0.2.8.tar.gz"
+sha512sums="8840725d2f1de59bebc8c49cf68a6712822a4e7b6ba9078713f80e3c35a39135565a1a885edab43a562f895e11b8f5d8d666d57d9b3814dabb661f46498515bd farstream-0.2.9.tar.gz
+ea863d7e72e6c0311c1e6f4718721f4f03955e0c9a61066db833cc0b73246b27387067abfe677f594c6a132c7e3836de50cc216903ba12e286638988f41e3bd5 make43.patch"
diff --git a/user/farstream/make43.patch b/user/farstream/make43.patch
new file mode 100644
index 000000000..7b1ec9a9e
--- /dev/null
+++ b/user/farstream/make43.patch
@@ -0,0 +1,38 @@
+From 54987d445ea714b467d901b7daf8c09ed0644189 Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@freedesktop.org>
+Date: Thu, 12 Mar 2020 14:07:23 +0100
+Subject: [PATCH] build: Adapt to backwards incompatible change in GNU Make 4.3
+
+GNU Make 4.3 has a backwards incompatible change affecting the use of
+number signs or hashes (ie., #) inside function invocations. See:
+https://lists.gnu.org/archive/html/info-gnu/2020-01/msg00004.html
+
+In this case, it would expand the '\#' in the '\n\#include \"$(h)\"'
+argument to the foreach call to '\#', not '#'. This would lead to
+spurious backslashes in front of the '#include' directives in the
+generated fs-enumtypes.c file.
+
+Spotted by Ernestas Kulik.
+
+https://gitlab.freedesktop.org/farstream/farstream/-/merge_requests/4
+---
+ common-modified/gst-glib-gen.mak | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/common-modified/gst-glib-gen.mak b/common-modified/gst-glib-gen.mak
+index 14f1ba37c788..2247a41c49ea 100644
+--- a/common-modified/gst-glib-gen.mak
++++ b/common-modified/gst-glib-gen.mak
+@@ -6,7 +6,8 @@
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++hash:=\#
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(hash)include \"$(h)\")
+
+ # these are all the rules generating the relevant files
+ $(glib_gen_basename)-enumtypes.h: $(glib_enum_headers)
+--
+2.24.1
+