summaryrefslogtreecommitdiff
path: root/user/felinks
diff options
context:
space:
mode:
authorNathan <ndowens@artixlinux.org>2020-10-20 21:05:58 +0000
committerNathan Owens <ndowens@artixlinux.org>2020-10-25 22:56:47 +0000
commitb53827110e696959549c9cdf93da07b6c03519cf (patch)
tree38ddcd99a2bd4fb9cc5a48faa030e80b13961562 /user/felinks
parent60c5b0f127e002057c3e057b59da6178808d59d4 (diff)
downloadpackages-b53827110e696959549c9cdf93da07b6c03519cf.tar.gz
packages-b53827110e696959549c9cdf93da07b6c03519cf.tar.bz2
packages-b53827110e696959549c9cdf93da07b6c03519cf.tar.xz
packages-b53827110e696959549c9cdf93da07b6c03519cf.zip
user/felinks: new package
Diffstat (limited to 'user/felinks')
-rw-r--r--user/felinks/APKBUILD46
-rw-r--r--user/felinks/gettext-tiny.patch14
2 files changed, 60 insertions, 0 deletions
diff --git a/user/felinks/APKBUILD b/user/felinks/APKBUILD
new file mode 100644
index 000000000..408763e13
--- /dev/null
+++ b/user/felinks/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Nathan <ndowens@artixlinux.org>
+# Maintainer: Nathan <ndowens@artixlinux.org>
+pkgname=felinks
+pkgver=0.13.5
+pkgrel=0
+pkgdesc="A text mode web browser"
+url="https://github.com/rkd77/felinks"
+arch="all"
+license="GPL-2.0+"
+depends=""
+makedepends="autoconf automake bzip2-dev gettext-tiny openssl-dev zlib-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rkd77/felinks/archive/v$pkgver.tar.gz
+ gettext-tiny.patch
+ "
+
+prepare() {
+ default_prepare
+ update_config_sub
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-nls
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rm -rf "$pkgdir"/usr/lib
+}
+
+sha512sums="786f6142c03bca4a47a1043ca4f9c36aab431d192eb13bcad14c1da391f5746779a8f65e53eb781dff79f619ceb3ed30ef939eae8d81f64251fad9b803c0ae7b felinks-0.13.5.tar.gz
+327a3b3193d1ddac891e5c46caf11a3dd946ca0a49d214a61303733eddb3e181c73a8b8d78962dc6e589b9401c7e56698154acade4d321515145cc85db834195 gettext-tiny.patch"
diff --git a/user/felinks/gettext-tiny.patch b/user/felinks/gettext-tiny.patch
new file mode 100644
index 000000000..27c2667d4
--- /dev/null
+++ b/user/felinks/gettext-tiny.patch
@@ -0,0 +1,14 @@
+gettext-tiny's msgfmt tries to use "--" as a literal output file (note
+that --statistics is ignored)
+
+--- felinks-0.13.5/po/Makefile 2020-08-30 14:31:52.000000000 +0000
++++ felinks-0.13.5/po/Makefile 2020-10-24 21:23:18.736882854 +0000
+@@ -22,7 +22,7 @@ POTFILES_ABS_LIST = potfiles.list
+ POTFILES_REL = $(shell find $(top_srcdir)/src/ -name '*.[ch]' -o -name options.inc -o -name 'actions-*.inc' | sort)
+
+ quiet_cmd_gmsgfmt = ' [$(PO_COLOR)GMSGFMT$(END_COLOR)] $(RELPATH)$(@)'
+- cmd_gmsgfmt = rm -f -- "$@" && $(GMSGFMT) --statistics -o "$@" -- "$<"
++ cmd_gmsgfmt = rm -f -- "$@" && $(GMSGFMT) --statistics -o "$@" "$<"
+
+
+ # Distributed elinks-*.tar.gz packages include po/*.gmo files, so that