summaryrefslogtreecommitdiff
path: root/user/firefox-esr/fix-seccomp-bpf.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-26 21:27:57 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-26 21:27:57 -0500
commit104e540fe2f63e78b86a61cb41e3ecb2f5451d65 (patch)
treee82d6599be3c39a68026ae3e3adc018348a6c17d /user/firefox-esr/fix-seccomp-bpf.patch
parentc2fa058ba2ced4f6780e42495aebc02869b2ddf8 (diff)
downloadpackages-104e540fe2f63e78b86a61cb41e3ecb2f5451d65.tar.gz
packages-104e540fe2f63e78b86a61cb41e3ecb2f5451d65.tar.bz2
packages-104e540fe2f63e78b86a61cb41e3ecb2f5451d65.tar.xz
packages-104e540fe2f63e78b86a61cb41e3ecb2f5451d65.zip
user/firefox-esr: I present Adélie's worst APKBUILD
Diffstat (limited to 'user/firefox-esr/fix-seccomp-bpf.patch')
-rw-r--r--user/firefox-esr/fix-seccomp-bpf.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/user/firefox-esr/fix-seccomp-bpf.patch b/user/firefox-esr/fix-seccomp-bpf.patch
new file mode 100644
index 000000000..47cde56c7
--- /dev/null
+++ b/user/firefox-esr/fix-seccomp-bpf.patch
@@ -0,0 +1,14 @@
+--- a/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc.orig 2015-09-23 09:10:08.812740571 +0200
++++ b/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc 2015-09-23 09:11:38.404746155 +0200
+@@ -23,6 +23,11 @@
+ #include "sandbox/linux/services/android_ucontext.h"
+ #endif
+
++// musl libc defines siginfo_t __si_fields instead of _sifields
++#if defined(OS_LINUX) && !defined(__GLIBC__)
++#define _sifields __si_fields
++#endif
++
+ namespace {
+
+ struct arch_sigsys {