summaryrefslogtreecommitdiff
path: root/user/firefox-esr/rust-32bit.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-19 02:10:20 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-21 02:08:32 -0600
commitdfe2d88752285a8da3bb1501caf9e804c5294150 (patch)
treec900c6d56f496734ccd7f586caa0bc6cbea61030 /user/firefox-esr/rust-32bit.patch
parentf79ddfd3022bb02ebe179c931df2d1f481164884 (diff)
downloadpackages-dfe2d88752285a8da3bb1501caf9e804c5294150.tar.gz
packages-dfe2d88752285a8da3bb1501caf9e804c5294150.tar.bz2
packages-dfe2d88752285a8da3bb1501caf9e804c5294150.tar.xz
packages-dfe2d88752285a8da3bb1501caf9e804c5294150.zip
user/firefox-esr: Update to 91.13.0
It still works on ppc64! Even with VP8/VP9 video!
Diffstat (limited to 'user/firefox-esr/rust-32bit.patch')
-rw-r--r--user/firefox-esr/rust-32bit.patch50
1 files changed, 31 insertions, 19 deletions
diff --git a/user/firefox-esr/rust-32bit.patch b/user/firefox-esr/rust-32bit.patch
index f9281cb7a..cff36e90b 100644
--- a/user/firefox-esr/rust-32bit.patch
+++ b/user/firefox-esr/rust-32bit.patch
@@ -1,20 +1,32 @@
---- firefox-68.1.0/config/makefiles/rust.mk.old 2019-08-26 16:52:20.000000000 +0000
-+++ firefox-68.1.0/config/makefiles/rust.mk 2019-10-03 21:17:55.062373830 +0000
-@@ -47,7 +47,7 @@
- ifndef DEVELOPER_OPTIONS
- ifndef MOZ_DEBUG_RUST
- # Enable link-time optimization for release builds.
--cargo_rustc_flags += -C lto
-+# OOMs on 32-bit machines: cargo_rustc_flags += -C lto
- endif
- endif
+--- firefox-91.13.0/config/makefiles/rust.mk.old 2022-08-15 13:04:32.000000000 -0500
++++ firefox-91.13.0/config/makefiles/rust.mk 2022-11-15 01:35:10.150096648 -0600
+@@ -64,19 +64,19 @@
+ # These flags are passed via `cargo rustc` and only apply to the final rustc
+ # invocation (i.e., only the top-level crate, not its dependencies).
+ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
+-ifndef DEVELOPER_OPTIONS
+-ifndef MOZ_DEBUG_RUST
++#ifndef DEVELOPER_OPTIONS
++#ifndef MOZ_DEBUG_RUST
+ # Enable link-time optimization for release builds, but not when linking
+ # gkrust_gtest. And not when doing cross-language LTO.
+-ifndef MOZ_LTO_RUST_CROSS
+-ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
+-cargo_rustc_flags += -Clto
+-endif
++#ifndef MOZ_LTO_RUST_CROSS
++#ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
++#cargo_rustc_flags += -Clto
++#endif
+ # We need -Cembed-bitcode=yes for all crates when using -Clto.
+-RUSTFLAGS += -Cembed-bitcode=yes
+-endif
+-endif
+-endif
++#RUSTFLAGS += -Cembed-bitcode=yes
++#endif
++#endif
++#endif
-@@ -246,7 +246,7 @@
- ifndef DEVELOPER_OPTIONS
- ifndef MOZ_DEBUG_RUST
- ifeq ($(OS_ARCH), Linux)
-- $(call py_action,check_binary,--target --networking $@)
-+# Fails because we disable LTO: $(call py_action,check_binary,--target --networking $@)
- endif
- endif
- endif
+ ifdef CARGO_INCREMENTAL
+ export CARGO_INCREMENTAL