summaryrefslogtreecommitdiff
path: root/user/font-adobe-utopia-75dpi
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-01 23:57:19 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-01 23:57:19 +0000
commit0ce0071dd83556a0fbba81321dab379f5c332946 (patch)
treea1401e599077fbe31b7610e7e452afa9f9807eab /user/font-adobe-utopia-75dpi
parent1aaca306673c5cd46d95c07f23f78bc181e7bfd2 (diff)
downloadpackages-0ce0071dd83556a0fbba81321dab379f5c332946.tar.gz
packages-0ce0071dd83556a0fbba81321dab379f5c332946.tar.bz2
packages-0ce0071dd83556a0fbba81321dab379f5c332946.tar.xz
packages-0ce0071dd83556a0fbba81321dab379f5c332946.zip
user/font-adobe-utopia-75dpi: new package
Diffstat (limited to 'user/font-adobe-utopia-75dpi')
-rw-r--r--user/font-adobe-utopia-75dpi/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/user/font-adobe-utopia-75dpi/APKBUILD b/user/font-adobe-utopia-75dpi/APKBUILD
new file mode 100644
index 000000000..338f6e0ee
--- /dev/null
+++ b/user/font-adobe-utopia-75dpi/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=font-adobe-utopia-75dpi
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="75dpi Utopia X11 font from Adobe"
+url="https://www.X.Org/"
+arch="noarch"
+# Okay.
+# This is really hairy, but Fedora Legal says the TUG license can apply to the
+# X11 distribution[1][2]; it's almost MIT style, but you have to rename the
+# font if you modify it in any way.
+# [1]: https://fedoraproject.org/wiki/Legal_considerations_for_fonts
+# [2]: https://src.fedoraproject.org/cgit/rpms/xorg-x11-fonts.git/tree/xorg-x11-fonts.spec
+license="Utopia"
+depends=""
+makedepends="bdftopcf fontconfig font-util-dev mkfontdir util-macros"
+subpackages=""
+source="https://www.x.org/releases/individual/font/font-adobe-utopia-75dpi-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c569af760a62b00738be65546364587638e8c46e4a0765013747e9595d51bc0633908c72359e42e7ebf6240fdc6294b51512c0a096a5fe64b2bd300ccbff7b92 font-adobe-utopia-75dpi-1.0.4.tar.bz2"