summaryrefslogtreecommitdiff
path: root/user/free42
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 23:10:12 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 23:10:12 +0000
commit24629e3a525a5e9af9a59fd3734abee0b7b9f115 (patch)
tree330edd809b786820341c3d3bfe86147d28eb97ce /user/free42
parent0bb280b4b7d115e5288eecabeb78543a6e43d171 (diff)
downloadpackages-24629e3a525a5e9af9a59fd3734abee0b7b9f115.tar.gz
packages-24629e3a525a5e9af9a59fd3734abee0b7b9f115.tar.bz2
packages-24629e3a525a5e9af9a59fd3734abee0b7b9f115.tar.xz
packages-24629e3a525a5e9af9a59fd3734abee0b7b9f115.zip
user/free42: fix build on signed char platforms (x86*), HTTPS
Diffstat (limited to 'user/free42')
-rw-r--r--user/free42/APKBUILD17
-rw-r--r--user/free42/libx11.patch4
-rw-r--r--user/free42/patch.patch8
-rw-r--r--user/free42/unsigned-char.patch15
4 files changed, 30 insertions, 14 deletions
diff --git a/user/free42/APKBUILD b/user/free42/APKBUILD
index ba8814388..c0f490ea0 100644
--- a/user/free42/APKBUILD
+++ b/user/free42/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=free42
pkgver=2.0.22
-pkgrel=1
+pkgrel=2
pkgdesc="Scientific programmable calculator"
-url="http://thomasokken.com/free42/"
+url="https://thomasokken.com/free42/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0-only AND Public-Domain"
@@ -15,11 +15,12 @@ source="https://distfiles.adelielinux.org/source/free42-nologo-$pkgver.tgz
free42.desktop
libx11.patch
patch.patch
+ unsigned-char.patch
"
-builddir="$srcdir/free42-nologo-$pkgver/gtk"
+builddir="$srcdir/free42-nologo-$pkgver"
build() {
- cd "$builddir"
+ cd "$builddir"/gtk
local SAVE_CFLAGS
SAVE_CFLAGS=$CFLAGS
unset CFLAGS
@@ -29,13 +30,13 @@ build() {
}
package() {
- cd "$builddir"
- install -D -m755 free42dec "$pkgdir"/usr/bin/free42dec
+ install -D -m755 gtk/free42dec "$pkgdir"/usr/bin/free42dec
install -D -m644 "$srcdir"/free42.desktop \
"$pkgdir"/usr/share/applications/free42.desktop
}
sha512sums="865e8cce86a882aba10e7e756308e195a6675f0b6db4b881e7b7df67de95f5169ca801005e25dd0e61a70a5a0cd6a374b0cf58003251cdc9dc526a2506e18e1d free42-nologo-2.0.22.tgz
f52700d234719f4ee7cdd369fc5f28ade190ff77ed1a824cd2cdaeef62419700de3d85a28fd6ae378f904e018813dc4145ca4cc9f2669fdf50f3e13baa7ec634 free42.desktop
-f8434fd1c20f0dd40de5773615eaf798329870231f7ce66785a1bc8e208fa0a64919f48ac3eea5ab9ceb818570ae93f61b0e81baec4261bbdfbf04237108ab6a libx11.patch
-7b48609bff5466d81f42ed65405cd09e98fa675c087837b22caebab2b97420a34d1156399c3b18608bcae42896c12aa63a6f87515f5677587dfff6ed135dc760 patch.patch"
+470eb88936c65a053860af94955bf979973bad48c4b1f593598818f8ff0c39c4869613a05ad0e82b7a3fc6ce19fa7b8642a38e726d4a48e3fe63a9cbac8a45d6 libx11.patch
+33afc0d0deb88143b3ec0a09fd2ba3de14d6ad269c9ecff55c9e89348d7bf76e2bbf880e0eef9a2c71eedb1da9136051a471d4aaaf9aa5acd4e992964a69692b patch.patch
+2e2e6c5a00de96f2ca1c61a0039a945bf0416c889b9131abf89c6eca4d8816ff0144c32634ac7c7b112fc1bd8cd6d816f22f2aed31bde59b96a79b9588235a02 unsigned-char.patch"
diff --git a/user/free42/libx11.patch b/user/free42/libx11.patch
index 54c4c6cc0..aa07ba2d1 100644
--- a/user/free42/libx11.patch
+++ b/user/free42/libx11.patch
@@ -1,5 +1,5 @@
---- gtk/Makefile.old 2019-01-13 14:52:39.000000000 +0000
-+++ gtk/Makefile 2019-01-17 01:38:40.500000000 +0000
+--- free42/gtk/Makefile.old 2019-01-13 14:52:39.000000000 +0000
++++ free42/gtk/Makefile 2019-01-17 01:38:40.500000000 +0000
@@ -35,7 +35,7 @@
-D_WCHAR_T_DEFINED
diff --git a/user/free42/patch.patch b/user/free42/patch.patch
index e84b3f7b8..f79bb6c8e 100644
--- a/user/free42/patch.patch
+++ b/user/free42/patch.patch
@@ -1,5 +1,5 @@
---- gtk/intel-lib-linux.patch.old 2019-01-13 14:52:39.000000000 +0000
-+++ gtk/intel-lib-linux.patch 2019-01-17 01:27:01.470000000 +0000
+--- free42/gtk/intel-lib-linux.patch.old 2019-01-13 14:52:39.000000000 +0000
++++ free42/gtk/intel-lib-linux.patch 2019-01-17 01:27:01.470000000 +0000
@@ -1668,3 +1668,62 @@
}
@@ -63,8 +63,8 @@
+ else
+ __TMP := $(strip $(subst /, ,$(firstword $(CC))))
+ CC_NAME := $(word $(words $(__TMP)), $(__TMP))
---- gtk/intel-lib-linux.patch.old 2019-01-23 03:43:48.830000000 +0000
-+++ gtk/intel-lib-linux.patch 2019-01-23 03:46:18.170000000 +0000
+--- free42/gtk/intel-lib-linux.patch.old 2019-01-23 03:43:48.830000000 +0000
++++ free42/gtk/intel-lib-linux.patch 2019-01-23 03:46:18.170000000 +0000
@@ -1727,3 +1727,14 @@
else
__TMP := $(strip $(subst /, ,$(firstword $(CC))))
diff --git a/user/free42/unsigned-char.patch b/user/free42/unsigned-char.patch
new file mode 100644
index 000000000..af3f47ef5
--- /dev/null
+++ b/user/free42/unsigned-char.patch
@@ -0,0 +1,15 @@
+This only breaks on platforms where 'char' is signed.
+
+(currently, pmmx and x86_64)
+
+--- free42/common/core_display.cc.old 2019-01-13 14:52:39.000000000 +0000
++++ free42/common/core_display.cc 2019-04-17 23:01:56.398695993 +0000
+@@ -43,7 +43,7 @@
+ #endif
+
+
+-static char bigchars[130][5] =
++static unsigned char bigchars[130][5] =
+ {
+ { 0x08, 0x08, 0x2a, 0x08, 0x08 },
+ { 0x22, 0x14, 0x08, 0x14, 0x22 },