summaryrefslogtreecommitdiff
path: root/user/freeglut/glvnd.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-26 09:09:02 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-29 04:55:39 -0600
commita33c1f93a2c22e47ded20a96979911eea4a8d743 (patch)
tree03c00b4318109e9fd385aaadb6cab3d0291b1314 /user/freeglut/glvnd.patch
parent271f2f0368391d1a99f1e408548a8d32e6cad748 (diff)
downloadpackages-a33c1f93a2c22e47ded20a96979911eea4a8d743.tar.gz
packages-a33c1f93a2c22e47ded20a96979911eea4a8d743.tar.bz2
packages-a33c1f93a2c22e47ded20a96979911eea4a8d743.tar.xz
packages-a33c1f93a2c22e47ded20a96979911eea4a8d743.zip
user/freeglut: Use GLVND for OpenGL
Includes a patch to the CMake to use libOpenGL and libGLX instead of the legacy libGL. We also explicitly set GLVND instead of LEGACY for the FindOpenGL module.
Diffstat (limited to 'user/freeglut/glvnd.patch')
-rw-r--r--user/freeglut/glvnd.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/user/freeglut/glvnd.patch b/user/freeglut/glvnd.patch
new file mode 100644
index 000000000..123e943b7
--- /dev/null
+++ b/user/freeglut/glvnd.patch
@@ -0,0 +1,13 @@
+This allows us to link to the new GLVND libraries. Otherwise, there will be linker errors.
+
+--- freeglut-3.2.2/CMakeLists.txt.old 2022-02-06 10:50:52.000000000 +0000
++++ freeglut-3.2.2/CMakeLists.txt 2024-11-26 12:50:25.436599428 +0000
+@@ -264,7 +264,7 @@
+ LIST(APPEND LIBS GLESv2 GLESv1_CM EGL)
+ ELSE()
+ FIND_PACKAGE(OpenGL REQUIRED)
+- LIST(APPEND LIBS ${OPENGL_gl_LIBRARY})
++ LIST(APPEND LIBS ${OPENGL_opengl_LIBRARY} ${OPENGL_glx_LIBRARY})
+ INCLUDE_DIRECTORIES(${OPENGL_INCLUDE_DIR})
+ ENDIF()
+