summaryrefslogtreecommitdiff
path: root/user/frei0r-plugins
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-03 00:04:58 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-03 00:04:58 +0000
commit836cac6486edfbf9c47afd588eef853292090209 (patch)
treecea722d366bd834dbef4d30195ea9dde7b23781b /user/frei0r-plugins
parent7059f1727d6929d5cff9b82fe84dbffcb2b93e5f (diff)
downloadpackages-836cac6486edfbf9c47afd588eef853292090209.tar.gz
packages-836cac6486edfbf9c47afd588eef853292090209.tar.bz2
packages-836cac6486edfbf9c47afd588eef853292090209.tar.xz
packages-836cac6486edfbf9c47afd588eef853292090209.zip
user/frei0r-plugins: Bump to 1.7.0
Diffstat (limited to 'user/frei0r-plugins')
-rw-r--r--user/frei0r-plugins/APKBUILD14
-rw-r--r--user/frei0r-plugins/facebl0r-opencv-3.4.3.patch22
2 files changed, 4 insertions, 32 deletions
diff --git a/user/frei0r-plugins/APKBUILD b/user/frei0r-plugins/APKBUILD
index bbfd1c2ca..989dcc871 100644
--- a/user/frei0r-plugins/APKBUILD
+++ b/user/frei0r-plugins/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=frei0r-plugins
-pkgver=1.6.1
+pkgver=1.7.0
pkgrel=0
pkgdesc="A minimalistic plugin API for video sources and filters"
url=" "
@@ -12,19 +12,15 @@ depends=""
makedepends="opencv-dev gavl-dev file cairo-dev doxygen
automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://files.dyne.org/frei0r/releases/frei0r-plugins-$pkgver.tar.gz
- facebl0r-opencv-3.4.3.patch
- "
+source="https://files.dyne.org/frei0r/releases/frei0r-plugins-$pkgver.tar.gz"
prepare() {
default_prepare
- cd "$builddir"
- touch README AUTHORS ChangeLog TODO
+ touch README.md AUTHORS ChangeLog TODO
autoreconf -i
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,9 +29,7 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="843790389e6de83817d1c3744a91d3365864bb0c22cf6598707ccba5ec8933f6209434011cde1303e16edd89f6cde2f22aa1fb6eca3548d892a2c77332c44aac frei0r-plugins-1.6.1.tar.gz
-785ff3459f371620780f274b82702c8f6625d78fcd6000fddca0585e3aeaa0af57fd9d9444c4d0f1ca47e84b47b8a2fca4b86fa44ebe93487948eb8f4a193503 facebl0r-opencv-3.4.3.patch"
+sha512sums="8c80e8e0ce8c302e633ea1f6ff4e2a141fd7a8bcb7fce25dc7f1f6521be11258a3efa1074c224c7323e6a17bc405413385be193a5c787e2f276252b50477ebce frei0r-plugins-1.7.0.tar.gz"
diff --git a/user/frei0r-plugins/facebl0r-opencv-3.4.3.patch b/user/frei0r-plugins/facebl0r-opencv-3.4.3.patch
deleted file mode 100644
index f3d4f46bb..000000000
--- a/user/frei0r-plugins/facebl0r-opencv-3.4.3.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From b0a06d52e39438fae2afbf98bafe6c794d13b83e Mon Sep 17 00:00:00 2001
-From: Christoph Willing <chris.willing@linux.com>
-Date: Sat, 14 Jul 2018 21:34:03 +1000
-Subject: [PATCH] Include opencv2/imgproc.hpp for CV_RGB()
-
-Signed-off-by: Christoph Willing <chris.willing@linux.com>
----
- src/filter/facebl0r/facebl0r.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/filter/facebl0r/facebl0r.cpp b/src/filter/facebl0r/facebl0r.cpp
-index 6d6e8f2..823462a 100644
---- a/src/filter/facebl0r/facebl0r.cpp
-+++ b/src/filter/facebl0r/facebl0r.cpp
-@@ -19,6 +19,7 @@
- #include <stdlib.h>
- #include <opencv/cv.h>
- #include <opencv/highgui.h>
-+#include <opencv2/imgproc.hpp>
-
- #include <frei0r.hpp>
- #include <frei0r_math.h>