summaryrefslogtreecommitdiff
path: root/user/gambit-c/fix-incompatible-stat-usage.patch
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-12-01 11:09:15 -0600
committerZach van Rijn <me@zv.io>2022-12-01 22:31:02 +0000
commit3fe3b6f911534b724e98653d21b287e6f5503280 (patch)
treea0716275bbdc92b8eef75b8cbba35192a3274c8e /user/gambit-c/fix-incompatible-stat-usage.patch
parent7d36744638d6fdd845e3a548c49c64896b094d57 (diff)
downloadpackages-3fe3b6f911534b724e98653d21b287e6f5503280.tar.gz
packages-3fe3b6f911534b724e98653d21b287e6f5503280.tar.bz2
packages-3fe3b6f911534b724e98653d21b287e6f5503280.tar.xz
packages-3fe3b6f911534b724e98653d21b287e6f5503280.zip
user/gambit-c: new package.
Diffstat (limited to 'user/gambit-c/fix-incompatible-stat-usage.patch')
-rw-r--r--user/gambit-c/fix-incompatible-stat-usage.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/user/gambit-c/fix-incompatible-stat-usage.patch b/user/gambit-c/fix-incompatible-stat-usage.patch
new file mode 100644
index 000000000..ed046a88c
--- /dev/null
+++ b/user/gambit-c/fix-incompatible-stat-usage.patch
@@ -0,0 +1,21 @@
+Illegal option 's'.
+
+diff -ur a/doc/makefile.in b/doc/makefile.in
+--- a/doc/makefile.in 2022-12-01 12:16:24.110528979 -0600
++++ b/doc/makefile.in 2022-12-01 12:41:45.384526329 -0600
+@@ -129,14 +129,7 @@
+ version.txi: stamp.vti
+
+ stamp.vti: gambit.txi $(rootfromhere)/configure.ac
+- # we need this mess because "date" and "stat"
+- # don't behave the same on Linux and BSD
+- st_mtime="`stat -s gambit.txi | sed -e 's/.*st_mtime=//g' -e 's/ .*//g'`"; \
+- if [ "$$st_mtime" = "" ]; then \
+- mtime="`date -r gambit.txi '+%B %d, %Y'`"; \
+- else \
+- mtime="`date -r $$st_mtime '+%B %d, %Y'`"; \
+- fi; \
++ mtime="`date -r gambit.txi '+%B %d, %Y'`";
+ echo "@set EDITION $(PACKAGE_VERSION)" > version.tmp; \
+ echo "@set UPDATED $$mtime" >> version.tmp; \
+ echo "@set VERSION $(PACKAGE_VERSION)" >> version.tmp