summaryrefslogtreecommitdiff
path: root/user/gdk-pixbuf/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/gdk-pixbuf/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/gdk-pixbuf/APKBUILD')
-rw-r--r--user/gdk-pixbuf/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/user/gdk-pixbuf/APKBUILD b/user/gdk-pixbuf/APKBUILD
index a12334d2e..7377083bb 100644
--- a/user/gdk-pixbuf/APKBUILD
+++ b/user/gdk-pixbuf/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gdk-pixbuf
-pkgver=2.38.2
+pkgver=2.40.0
pkgrel=0
pkgdesc="GTK+ image loading library"
url="https://www.gtk.org/"
@@ -13,9 +13,7 @@ makedepends="glib-dev gobject-introspection-dev libjpeg-turbo-dev libpng-dev
install="$pkgname.pre-deinstall"
triggers="$pkgname.trigger=/usr/lib/gdk-pixbuf-2.0/*/loaders"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz
- "
-replaces="gtk+"
+source="https://download.gnome.org/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz"
# secfixes:
# 2.36.6-r1:
@@ -24,10 +22,11 @@ replaces="gtk+"
# - CVE-2017-6314
build() {
- mkdir build
- cd build
- meson -Dprefix=/usr -Dinstalled_tests=false
- ninja
+ meson \
+ -Dprefix=/usr \
+ -Dinstalled_tests=false \
+ build
+ ninja -C build
}
check() {
@@ -38,4 +37,4 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="b0f83cca9bfbe45dab200b19a5ec6231b628c09633fd41348f433c226d523c2f9b805d41e4d955e9fd65c5b6d24df59c7c94193032379d6f09b0472ae988a0c1 gdk-pixbuf-2.38.2.tar.xz"
+sha512sums="6512befd379494dbfd89a16fc4c92641842eb7b82fc820ec83a5b057526209947db646570db1124c073b0ef69c117bdf0f8d3fea807e302a4950db39187c35aa gdk-pixbuf-2.40.0.tar.xz"