summaryrefslogtreecommitdiff
path: root/user/gnucobol/keep-debug-flags.patch
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-06-29 12:02:14 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-06-29 12:02:14 +0000
commit4ba63a0284e5b55dba86301653ccdbb7e6a260ba (patch)
treeeb8eaf0c8b33efb90b85246692510b2a2985beb8 /user/gnucobol/keep-debug-flags.patch
parentbe390a5a674f172cde107f29b60e4dce79cee531 (diff)
parentef2c616773b00d4cc14eca7da2e4fb4b42ee2882 (diff)
downloadpackages-4ba63a0284e5b55dba86301653ccdbb7e6a260ba.tar.gz
packages-4ba63a0284e5b55dba86301653ccdbb7e6a260ba.tar.bz2
packages-4ba63a0284e5b55dba86301653ccdbb7e6a260ba.tar.xz
packages-4ba63a0284e5b55dba86301653ccdbb7e6a260ba.zip
Merge branch 'gnucobol' into 'master'
user/gnucobol: new package See merge request !260
Diffstat (limited to 'user/gnucobol/keep-debug-flags.patch')
-rw-r--r--user/gnucobol/keep-debug-flags.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/user/gnucobol/keep-debug-flags.patch b/user/gnucobol/keep-debug-flags.patch
new file mode 100644
index 000000000..40c188802
--- /dev/null
+++ b/user/gnucobol/keep-debug-flags.patch
@@ -0,0 +1,43 @@
+--- gnucobol-3.0-rc1/configure.ac 2018-04-22 22:00:19.000000000 +0000
++++ gnucobol-3.0-rc1/configure.ac 2019-06-28 12:09:56.160772995 +0000
+@@ -1216,40 +1216,6 @@
+ fi
+
+
+-# Include CFLAGS / CPPFLAGS in COB_CFLAGS without optimization/debug options.
+-
+-if test "x$CFLAGS" != "x"; then
+- cob_temp_flags="$CFLAGS"
+-else
+- cob_temp_flags=""
+-fi
+-if test "x$CPPFLAGS" != "x"; then
+- if test "x$cob_temp_flags" != "x"; then
+- cob_temp_flags="$CPPFLAGS $cob_temp_flags"
+- else
+- cob_temp_flags="$CPPFLAGS"
+- fi
+-fi
+-if test "x$cob_temp_flags" != "x"; then
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-g3//' -e 's/-g//' -e 's/ $//' -e 's/^ //'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/@<:@+-@:>@O@<:@0-9s@:>@//' -e 's/ $//' -e 's/^ //'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-O//' -e 's/ $//' -e 's/^ //'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-fmessage-length=0//'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-D_FORTIFY_SOURCE=.//'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-fstack-protector-strong//'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-fstack-protector-all//'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-fstack-protector//'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-funwind-tables//'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/-fasynchronous-unwind-tables//'`
+- cob_temp_flags=`echo "$cob_temp_flags" | sed -e 's/ */ /g' -e 's/ $//' -e 's/^ //'`
+-fi
+-
+-if test "x$cob_temp_flags" != "x"; then
+- COB_CFLAGS="$COB_CFLAGS $cob_temp_flags"
+-fi
+-unset cob_temp_flags
+-
+-
+ # Special stuff
+
+ AH_VERBATIM([_XOPEN_SOURCE_EXTENDED],