summaryrefslogtreecommitdiff
path: root/user/gobject-introspection
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-12-29 23:43:36 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-12-29 23:43:36 +0000
commit1f3a1b66721aa8c259d5f5ada4b5e55da526a2d6 (patch)
tree7cbb98829d65743daa3170d0d0225b7f978c9262 /user/gobject-introspection
parent24f28c6078af3dc5c105905046af4bf953b610f6 (diff)
downloadpackages-1f3a1b66721aa8c259d5f5ada4b5e55da526a2d6.tar.gz
packages-1f3a1b66721aa8c259d5f5ada4b5e55da526a2d6.tar.bz2
packages-1f3a1b66721aa8c259d5f5ada4b5e55da526a2d6.tar.xz
packages-1f3a1b66721aa8c259d5f5ada4b5e55da526a2d6.zip
user/gobject-introspection: we're in a pickle now boi
Diffstat (limited to 'user/gobject-introspection')
-rw-r--r--user/gobject-introspection/APKBUILD9
-rw-r--r--user/gobject-introspection/we-are-in-a-pickle.patch28
2 files changed, 34 insertions, 3 deletions
diff --git a/user/gobject-introspection/APKBUILD b/user/gobject-introspection/APKBUILD
index a4990adbf..85345d331 100644
--- a/user/gobject-introspection/APKBUILD
+++ b/user/gobject-introspection/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=gobject-introspection
pkgver=1.58.2
-pkgrel=0
+pkgrel=1
pkgdesc="Introspection system for GObject-based libraries"
url="https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
arch="all"
@@ -13,7 +13,9 @@ makedepends="$depends_dev bison flex glib-dev libffi-dev meson ninja python3-dev
checkdepends="sed"
subpackages="$pkgname-doc $pkgname-dev"
replaces="libgirepository"
-source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ we-are-in-a-pickle.patch
+ "
prepare() {
cd "$builddir"
@@ -46,4 +48,5 @@ dev() {
replaces="gobject-introspection"
}
-sha512sums="b516527a910702b26f8034ded463bdd28bb9db782ac77947ac2178ae3a41bd9e0390fff6155aca6e9ec92c6cf051314134322efae6937bd9cbcb4033df65c677 gobject-introspection-1.58.2.tar.xz"
+sha512sums="b516527a910702b26f8034ded463bdd28bb9db782ac77947ac2178ae3a41bd9e0390fff6155aca6e9ec92c6cf051314134322efae6937bd9cbcb4033df65c677 gobject-introspection-1.58.2.tar.xz
+106e36c04ab9035b92d7f34251c3af2c37fbbc538d2b96027735565df74314eb90a93288f1bc62c08742ff6ba525d72ea03306e3b32f48724a09548788466d3d we-are-in-a-pickle.patch"
diff --git a/user/gobject-introspection/we-are-in-a-pickle.patch b/user/gobject-introspection/we-are-in-a-pickle.patch
new file mode 100644
index 000000000..5262e2887
--- /dev/null
+++ b/user/gobject-introspection/we-are-in-a-pickle.patch
@@ -0,0 +1,28 @@
+From 945438608433a554b8d7077af648d60a9daf59f9 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sat, 8 Dec 2018 18:44:31 +0100
+Subject: [PATCH] cachestore: don't try to catch nonexisting
+ pickle.BadPickleGet. Fixes #159
+
+pickle.loads() can pretty much throw any kind of exception and we can't
+handle it besides ignoring it, so just catch all.
+---
+ giscanner/cachestore.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/giscanner/cachestore.py b/giscanner/cachestore.py
+index 58b3193c..857dc725 100644
+--- a/giscanner/cachestore.py
++++ b/giscanner/cachestore.py
+@@ -178,7 +178,7 @@ class CacheStore(object):
+ return None
+ try:
+ data = pickle.load(fd)
+- except (AttributeError, EOFError, ValueError, pickle.BadPickleGet):
++ except Exception:
+ # Broken cache entry, remove it
+ self._remove_filename(store_filename)
+ data = None
+--
+2.18.1
+