summaryrefslogtreecommitdiff
path: root/user/gst-plugins-bad
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-06-13 13:51:45 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-07-09 04:02:04 -0500
commit12e434543c289bb6a41b8b6313948b23a658adaa (patch)
tree53375bb644aad14a9b2658b4a1bba3730bfe7178 /user/gst-plugins-bad
parentc3ca9d815e6d59c7611a80786f2704aaeee98139 (diff)
downloadpackages-12e434543c289bb6a41b8b6313948b23a658adaa.tar.gz
packages-12e434543c289bb6a41b8b6313948b23a658adaa.tar.bz2
packages-12e434543c289bb6a41b8b6313948b23a658adaa.tar.xz
packages-12e434543c289bb6a41b8b6313948b23a658adaa.zip
user/gst-plugins-bad: add patch for 32-bit ARM
Closes: #1198
Diffstat (limited to 'user/gst-plugins-bad')
-rw-r--r--user/gst-plugins-bad/APKBUILD6
-rw-r--r--user/gst-plugins-bad/fix-arm-parser-alignment.patch32
2 files changed, 36 insertions, 2 deletions
diff --git a/user/gst-plugins-bad/APKBUILD b/user/gst-plugins-bad/APKBUILD
index 2ddff96a5..badfd94c0 100644
--- a/user/gst-plugins-bad/APKBUILD
+++ b/user/gst-plugins-bad/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gst-plugins-bad
pkgver=1.20.2
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer multimedia framework - Lower-quality plugins"
url="https://gstreamer.freedesktop.org/modules/gst-plugins-good.html"
arch="all"
@@ -23,6 +23,7 @@ source="https://gstreamer.freedesktop.org/src/$pkgname/$pkgname-$pkgver.tar.xz
curlhttpsrc.patch
mpegts.patch
fix-arm-test-alignment.patch
+ fix-arm-parser-alignment.patch
"
build() {
@@ -47,4 +48,5 @@ sha512sums="3f98973dc07ead745418e0a30f9f6b5c8d328e3d126f54d92c10ab5da04271768a5c
7f6023e766895ac8213f9dabd4d8acbeb03f18c2d98fa27865e7656c439e0ea97d02f9e9f0ea98205238ddb8f6473062af524b799d1da0cbe41a3055a11df250 camerabin.patch
d4bf36560db0e6391cfca84f928d7147bb6b170431c521e78253b29f6bccf122309e1f92e241808855dfa112b9a06e17c1b6ed4363e011a0693f82e1bfe7ea3e curlhttpsrc.patch
d70f409f86b072d689d51b87db6e9fb161c0914a381eccbf66f1ffcd61b9a793f9e4087cdd071e615aaa63687c6ee476f023239920dd1ebd0d3cde346031dc86 mpegts.patch
-566fbdc37c9f9fb5b671ecffa2f596a95f6431668ff8dd8b91bc827a280b5fb18a8fac3122a38f060263cb3f2d2138805af1e1c324eb619188f982c8cc575221 fix-arm-test-alignment.patch"
+566fbdc37c9f9fb5b671ecffa2f596a95f6431668ff8dd8b91bc827a280b5fb18a8fac3122a38f060263cb3f2d2138805af1e1c324eb619188f982c8cc575221 fix-arm-test-alignment.patch
+f394b1643a5d0943e8acd7e9ee11702ce3bbfb27242f3eac140b884ce7bb5dea725ab4bb0a28cbf9d435622dcc68ea0ee0bee1c51a520787c382167dd1e43583 fix-arm-parser-alignment.patch"
diff --git a/user/gst-plugins-bad/fix-arm-parser-alignment.patch b/user/gst-plugins-bad/fix-arm-parser-alignment.patch
new file mode 100644
index 000000000..63715380e
--- /dev/null
+++ b/user/gst-plugins-bad/fix-arm-parser-alignment.patch
@@ -0,0 +1,32 @@
+This patch differs from upstream in the following way(s):
+
+ * Paths changed to accommodate 'builddir'
+
+From 10930661ee8ab2f43078ece482c33ca74c2440fb Mon Sep 17 00:00:00 2001
+From: Zach van Rijn <me@zv.io>
+Date: Thu, 13 Jun 2024 09:11:30 -0500
+Subject: [PATCH] pcapparse: Avoid unaligned memory access
+
+Fixes: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/3602
+---
+ subprojects/gst-plugins-bad/gst/pcapparse/gstpcapparse.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/subprojects/gst-plugins-bad/gst/pcapparse/gstpcapparse.c b/subprojects/gst-plugins-bad/gst/pcapparse/gstpcapparse.c
+index 53e7ef6fc25..0a9c9a6063b 100644
+--- a/gst/pcapparse/gstpcapparse.c
++++ b/gst/pcapparse/gstpcapparse.c
+@@ -456,8 +456,8 @@ gst_pcap_parse_scan_frame (GstPcapParse * self,
+ return FALSE;
+
+ /* ip info */
+- ip_src_addr = *((guint32 *) (buf_ip + 12));
+- ip_dst_addr = *((guint32 *) (buf_ip + 16));
++ memcpy(&ip_src_addr, buf_ip + 12, sizeof(ip_src_addr));
++ memcpy(&ip_dst_addr, buf_ip + 16, sizeof(ip_dst_addr));
+ buf_proto = buf_ip + ip_header_size;
+ ip_packet_len = GUINT16_FROM_BE (*(guint16 *) (buf_ip + 2));
+
+--
+GitLab
+