summaryrefslogtreecommitdiff
path: root/user/gst-plugins-good
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-06-12 17:01:25 +0000
committerZach van Rijn <me@zv.io>2023-06-12 17:03:06 +0000
commit87761f90bac72283c35725a215a48d8e7b1a101c (patch)
treed1331556ac79578035079407a2a748bcce954e0a /user/gst-plugins-good
parentd688a3f21ac74e54b8a0d758329d1f0361500dd8 (diff)
downloadpackages-87761f90bac72283c35725a215a48d8e7b1a101c.tar.gz
packages-87761f90bac72283c35725a215a48d8e7b1a101c.tar.bz2
packages-87761f90bac72283c35725a215a48d8e7b1a101c.tar.xz
packages-87761f90bac72283c35725a215a48d8e7b1a101c.zip
user/gst-plugins-good: patch broken test. fixes #1025.
Diffstat (limited to 'user/gst-plugins-good')
-rw-r--r--user/gst-plugins-good/APKBUILD6
-rw-r--r--user/gst-plugins-good/fix-arm-test-alignment.patch16
2 files changed, 20 insertions, 2 deletions
diff --git a/user/gst-plugins-good/APKBUILD b/user/gst-plugins-good/APKBUILD
index 22f5a44ae..408a7fc3e 100644
--- a/user/gst-plugins-good/APKBUILD
+++ b/user/gst-plugins-good/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gst-plugins-good
pkgver=1.20.2
-pkgrel=0
+pkgrel=1
pkgdesc="GStreamer multimedia framework - Free, well-written plugins"
url="https://gstreamer.freedesktop.org/modules/gst-plugins-good.html"
arch="all"
@@ -19,6 +19,7 @@ subpackages="$pkgname-gtk $pkgname-lang"
ldpath="/usr/lib/gstreamer-1.0"
source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
drop-messages-interval-type.patch
+ fix-arm-test-alignment.patch
"
build() {
@@ -51,4 +52,5 @@ gtk() {
}
sha512sums="a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933 gst-plugins-good-1.20.2.tar.xz
-0f08a08d6f0e8303a9c899c5260f6ca2c0e0a41e1ca2a9c795c1cb1267a9003354cd0e5538022049a09784ba9000a4a60b7a0b07b38a18483ec30d9a86356e46 drop-messages-interval-type.patch"
+0f08a08d6f0e8303a9c899c5260f6ca2c0e0a41e1ca2a9c795c1cb1267a9003354cd0e5538022049a09784ba9000a4a60b7a0b07b38a18483ec30d9a86356e46 drop-messages-interval-type.patch
+3960a0ce93facee425ccc2f9ebce3f37c545b36df4177eb84cb244d4c08801db772288928987c64b9a9301e5f7b1f0f3e6be3cf130df1c1cf7ea85c64131fc27 fix-arm-test-alignment.patch"
diff --git a/user/gst-plugins-good/fix-arm-test-alignment.patch b/user/gst-plugins-good/fix-arm-test-alignment.patch
new file mode 100644
index 000000000..673ec7d83
--- /dev/null
+++ b/user/gst-plugins-good/fix-arm-test-alignment.patch
@@ -0,0 +1,16 @@
+diff -ur a/tests/check/elements/rtpbin_buffer_list.c b/tests/check/elements/rtpbin_buffer_list.c
+--- a/tests/check/elements/rtpbin_buffer_list.c 2023-06-12 16:31:48.734887801 +0000
++++ b/tests/check/elements/rtpbin_buffer_list.c 2023-06-12 16:54:58.883822559 +0000
+@@ -236,10 +236,8 @@
+ * most likely be changed in gstrtpbin.
+ */
+ fail_unless (info.data != NULL);
+- fail_unless_equals_uint64 (*(guint64 *) info.data,
+- *(guint64 *) rtp_header[index]);
+- fail_unless (*(guint16 *) (info.data + 12) ==
+- *(guint16 *) (rtp_header[index] + 12));
++ fail_unless (memcmp(info.data , rtp_header[index] , 8) == 0);
++ fail_unless (memcmp(info.data + 12, rtp_header[index] + 12, info.size - 12) == 0);
+
+ gst_memory_unmap (memory, &info);
+ gst_memory_unref (memory);