summaryrefslogtreecommitdiff
path: root/user/gst-plugins-good
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-06-12 18:39:05 +0000
committerZach van Rijn <me@zv.io>2023-06-12 18:39:05 +0000
commitaeef177ff67b31d0f1e2ab27d90652bf4a229894 (patch)
tree258c8c33a19911026451df7540abac72d79d6833 /user/gst-plugins-good
parent87761f90bac72283c35725a215a48d8e7b1a101c (diff)
downloadpackages-aeef177ff67b31d0f1e2ab27d90652bf4a229894.tar.gz
packages-aeef177ff67b31d0f1e2ab27d90652bf4a229894.tar.bz2
packages-aeef177ff67b31d0f1e2ab27d90652bf4a229894.tar.xz
packages-aeef177ff67b31d0f1e2ab27d90652bf4a229894.zip
user/gst-plugins-good: update (backport from upstream) fix for broken test.
Diffstat (limited to 'user/gst-plugins-good')
-rw-r--r--user/gst-plugins-good/APKBUILD4
-rw-r--r--user/gst-plugins-good/fix-arm-test-alignment.patch46
2 files changed, 38 insertions, 12 deletions
diff --git a/user/gst-plugins-good/APKBUILD b/user/gst-plugins-good/APKBUILD
index 408a7fc3e..bc8624aa0 100644
--- a/user/gst-plugins-good/APKBUILD
+++ b/user/gst-plugins-good/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gst-plugins-good
pkgver=1.20.2
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer multimedia framework - Free, well-written plugins"
url="https://gstreamer.freedesktop.org/modules/gst-plugins-good.html"
arch="all"
@@ -53,4 +53,4 @@ gtk() {
sha512sums="a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933 gst-plugins-good-1.20.2.tar.xz
0f08a08d6f0e8303a9c899c5260f6ca2c0e0a41e1ca2a9c795c1cb1267a9003354cd0e5538022049a09784ba9000a4a60b7a0b07b38a18483ec30d9a86356e46 drop-messages-interval-type.patch
-3960a0ce93facee425ccc2f9ebce3f37c545b36df4177eb84cb244d4c08801db772288928987c64b9a9301e5f7b1f0f3e6be3cf130df1c1cf7ea85c64131fc27 fix-arm-test-alignment.patch"
+b08c5013100dff428125dca9075641a8c528ccdcdf005b66b286cfe3b8b6f80c4b04f41d768883e98112107b857e17af68e2864a331f379bd7ea5027adc641d8 fix-arm-test-alignment.patch"
diff --git a/user/gst-plugins-good/fix-arm-test-alignment.patch b/user/gst-plugins-good/fix-arm-test-alignment.patch
index 673ec7d83..2b2a6a0c0 100644
--- a/user/gst-plugins-good/fix-arm-test-alignment.patch
+++ b/user/gst-plugins-good/fix-arm-test-alignment.patch
@@ -1,16 +1,42 @@
-diff -ur a/tests/check/elements/rtpbin_buffer_list.c b/tests/check/elements/rtpbin_buffer_list.c
---- a/tests/check/elements/rtpbin_buffer_list.c 2023-06-12 16:31:48.734887801 +0000
-+++ b/tests/check/elements/rtpbin_buffer_list.c 2023-06-12 16:54:58.883822559 +0000
-@@ -236,10 +236,8 @@
+From 57ced2fded938aa08d8727683a1823ae36170fc3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
+Date: Mon, 12 Jun 2023 19:24:15 +0100
+Subject: [PATCH] tests: rtpbin_buffer_list: fix possible unaligned read on
+ 32-bit ARM
+
+Fixes https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues/689
+---
+ .../tests/check/elements/rtpbin_buffer_list.c | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/subprojects/gst-plugins-good/tests/check/elements/rtpbin_buffer_list.c b/subprojects/gst-plugins-good/tests/check/elements/rtpbin_buffer_list.c
+index b804744352a..1c3d5cdd3a7 100644
+--- a/tests/check/elements/rtpbin_buffer_list.c
++++ b/tests/check/elements/rtpbin_buffer_list.c
+@@ -25,6 +25,12 @@
+ #include <gst/rtp/gstrtpbuffer.h>
+ #include <gst/rtp/gstrtcpbuffer.h>
+
++#if G_BYTE_ORDER == G_BIG_ENDIAN
++#define READ_UINT64(mem) GST_READ_UINT64_BE(mem)
++#else
++#define READ_UINT64(mem) GST_READ_UINT64_LE(mem)
++#endif
++
+ /* UDP/IP is assumed for bandwidth calculation */
+ #define UDP_IP_HEADER_OVERHEAD 28
+
+@@ -236,8 +242,8 @@ check_header (GstBuffer * buffer, guint index)
* most likely be changed in gstrtpbin.
*/
fail_unless (info.data != NULL);
- fail_unless_equals_uint64 (*(guint64 *) info.data,
- *(guint64 *) rtp_header[index]);
-- fail_unless (*(guint16 *) (info.data + 12) ==
-- *(guint16 *) (rtp_header[index] + 12));
-+ fail_unless (memcmp(info.data , rtp_header[index] , 8) == 0);
-+ fail_unless (memcmp(info.data + 12, rtp_header[index] + 12, info.size - 12) == 0);
++ fail_unless_equals_uint64 (READ_UINT64 (info.data),
++ READ_UINT64 (rtp_header[index]));
+ fail_unless (*(guint16 *) (info.data + 12) ==
+ *(guint16 *) (rtp_header[index] + 12));
- gst_memory_unmap (memory, &info);
- gst_memory_unref (memory);
+--
+GitLab
+