summaryrefslogtreecommitdiff
path: root/user/gtk+2.0/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 05:05:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 05:05:24 -0500
commit1b003691f4c0b002481fc174e77f241d14e22c1d (patch)
tree4095eac13b48a8665ceaa84bf45f470024b62bd3 /user/gtk+2.0/APKBUILD
parent08d3d6f68760fff8922660c16643de05fbf459ed (diff)
downloadpackages-1b003691f4c0b002481fc174e77f241d14e22c1d.tar.gz
packages-1b003691f4c0b002481fc174e77f241d14e22c1d.tar.bz2
packages-1b003691f4c0b002481fc174e77f241d14e22c1d.tar.xz
packages-1b003691f4c0b002481fc174e77f241d14e22c1d.zip
user/gtk+2.0: bump and fix \o/
Diffstat (limited to 'user/gtk+2.0/APKBUILD')
-rw-r--r--user/gtk+2.0/APKBUILD108
1 files changed, 108 insertions, 0 deletions
diff --git a/user/gtk+2.0/APKBUILD b/user/gtk+2.0/APKBUILD
new file mode 100644
index 000000000..30346191a
--- /dev/null
+++ b/user/gtk+2.0/APKBUILD
@@ -0,0 +1,108 @@
+# Maintainer:
+pkgname=gtk+2.0
+pkgver=2.24.32
+pkgrel=0
+subpkg=gtk-update-icon-cache
+pkgdesc="The GTK+ Toolkit (v2)"
+url="https://www.gtk.org/"
+arch="all"
+options="!check" # Requires xvfb, resulting in eventual circular dependency
+license="LGPL-2.0+"
+depends="shared-mime-info gtk-update-icon-cache"
+
+replaces="gtk+"
+replaces_dev="gtk+-dev"
+replaces_doc="gtk+-doc"
+
+depends_dev="
+ atk-dev
+ cairo-dev
+ libxdamage-dev
+ pango-dev
+ "
+# we add hicolor-icon-theme because the subpackage gtk-update-icon-cache
+# needs it. We need to force hicolor-icon-cache to be built before gtk+.2.0
+makedepends="
+ autoconf automake libtool
+ $depends_dev
+ cups-dev
+ expat-dev
+ gdk-pixbuf-dev
+ glib-dev
+ gnutls-dev
+ gobject-introspection-dev
+ gtk-doc
+ hicolor-icon-theme
+ libice-dev
+ libx11-dev
+ libxcomposite-dev
+ libxcursor-dev
+ libxext-dev
+ libxfixes-dev
+ libxrandr-dev
+ libxi-dev
+ zlib-dev"
+source="https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz
+ xid-collision-debug.patch
+ gtk2-fixdso.patch
+ "
+
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+triggers="$subpkg.trigger=/usr/share/icons/*"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $subpkg:icon_cache"
+langdir="/usr/lib/locale"
+builddir="$srcdir"/gtk+-$pkgver
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ libtoolize --force \
+ && aclocal -I m4 \
+ && autoconf \
+ && automake --add-missing
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-xinput=yes \
+ --without-libjasper \
+ --with-included-loaders=png \
+ --with-gdktarget=x11 \
+ --enable-cups \
+ --enable-man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+dev() {
+ mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/gtk-2.0 "$subpkgdir"/usr/share/
+ default_dev
+ replaces="gtk+2.0"
+ mv "$pkgdir"/usr/bin/gtk-builder-convert \
+ "$pkgdir"/usr/bin/gtk-demo \
+ "$subpkgdir"/usr/bin
+}
+
+icon_cache() {
+ depends="hicolor-icon-theme"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/"$subpkg" "$subpkgdir"/usr/bin
+}
+
+sha512sums="8e8fd9ae32f1d6fb544da260f00599f0f05090d910d767b06ef086ab4f1f8373a29bb0da9767761c9b5f4cfd51b5c45d0fa5d39b0428c839ddf0a579df806696 gtk+-2.24.32.tar.xz
+89e3223c86731a76b12d39245f1ec4cf8b4860ab1d11d74a10e5deb0db302f20b4bb5d9034da1d8aeb96369dbdeddcdd2f28943270dc501476c694562b960159 xid-collision-debug.patch
+95f28633a5164a2a9fec45ee1aa80bd1c07e0c5a7ac8d770b9c74af0909b7286b823eb634aa384cad609dc8799d2e6c9e8392c2732b9093076fdf94b4f6878b7 gtk2-fixdso.patch"