summaryrefslogtreecommitdiff
path: root/user/gtk+2.0
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-07 03:29:17 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-07 03:29:17 +0000
commit03c2cfa441a78e27f9389c883eabdcf7624c8ebc (patch)
tree5467f541ff156117320af1e8c6ccf80fa4fdde01 /user/gtk+2.0
parent208782f8684abe21c2a4cdcbd44afa47184c7e10 (diff)
downloadpackages-03c2cfa441a78e27f9389c883eabdcf7624c8ebc.tar.gz
packages-03c2cfa441a78e27f9389c883eabdcf7624c8ebc.tar.bz2
packages-03c2cfa441a78e27f9389c883eabdcf7624c8ebc.tar.xz
packages-03c2cfa441a78e27f9389c883eabdcf7624c8ebc.zip
user/gtk+2.0: overhaul (see commit msg)
* Insert static -lintl from gettext-tiny into build. This makes the GTK LOCALEDIR finally /usr/share/locale instead of /usr/lib/locale. * Remove old replaces= from Alpine. This isn't Alpine, we never had a gtk+. * Shuffle variables around to match Adélie preferred style. * Don't define a global `subpkg` variable for a single subpackage(???) * Modernise. * Take maintainership over.
Diffstat (limited to 'user/gtk+2.0')
-rw-r--r--user/gtk+2.0/APKBUILD54
1 files changed, 13 insertions, 41 deletions
diff --git a/user/gtk+2.0/APKBUILD b/user/gtk+2.0/APKBUILD
index 962b80c4e..9fee775c2 100644
--- a/user/gtk+2.0/APKBUILD
+++ b/user/gtk+2.0/APKBUILD
@@ -1,58 +1,32 @@
-# Maintainer:
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gtk+2.0
pkgver=2.24.32
-pkgrel=1
-subpkg=gtk-update-icon-cache
+pkgrel=2
pkgdesc="The GTK+ Toolkit (v2)"
url="https://www.gtk.org/"
arch="all"
options="!check" # Requires xvfb, resulting in eventual circular dependency
license="LGPL-2.0+"
depends="shared-mime-info gtk-update-icon-cache"
-
-replaces="gtk+"
-replaces_dev="gtk+-dev"
-replaces_doc="gtk+-doc"
-
depends_dev="libxdamage-dev"
# we add hicolor-icon-theme because the subpackage gtk-update-icon-cache
# needs it. We need to force hicolor-icon-cache to be built before gtk+.2.0
-makedepends="
- autoconf automake libtool
- $depends_dev
- atk-dev
- cairo-dev
- cups-dev
- expat-dev
- gdk-pixbuf-dev
- glib-dev
- gnutls-dev
- gobject-introspection-dev
- gtk-doc
- hicolor-icon-theme
- libice-dev
- libx11-dev
- libxcomposite-dev
- libxcursor-dev
- libxext-dev
- libxfixes-dev
- libxrandr-dev
- libxi-dev
- pango-dev
- zlib-dev"
+makedepends="autoconf automake libtool $depends_dev
+ atk-dev cairo-dev cups-dev expat-dev gdk-pixbuf-dev glib-dev gnutls-dev
+ gobject-introspection-dev gtk-doc hicolor-icon-theme libice-dev
+ libx11-dev libxcomposite-dev libxcursor-dev libxext-dev libxfixes-dev
+ libxrandr-dev libxi-dev pango-dev zlib-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang
+ gtk-update-icon-cache:icon_cache"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+triggers="gtk-update-icon-cache.trigger=/usr/share/icons/*"
source="https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz
xid-collision-debug.patch
gtk2-fixdso.patch
"
-
-install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
-triggers="$subpkg.trigger=/usr/share/icons/*"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $subpkg:icon_cache"
-langdir="/usr/lib/locale"
builddir="$srcdir"/gtk+-$pkgver
prepare() {
- cd "$builddir"
default_prepare
libtoolize --force \
&& aclocal -I m4 \
@@ -61,8 +35,7 @@ prepare() {
}
build() {
- cd "$builddir"
- ./configure \
+ LIBS="-lintl" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -80,7 +53,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -98,7 +70,7 @@ icon_cache() {
depends="hicolor-icon-theme"
mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/"$subpkg" "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/gtk-update-icon-cache "$subpkgdir"/usr/bin
}
sha512sums="8e8fd9ae32f1d6fb544da260f00599f0f05090d910d767b06ef086ab4f1f8373a29bb0da9767761c9b5f4cfd51b5c45d0fa5d39b0428c839ddf0a579df806696 gtk+-2.24.32.tar.xz