summaryrefslogtreecommitdiff
path: root/user/guile
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-08 17:18:40 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-08 17:18:40 -0500
commit36df2a269acd2a150d7713f07504213963f0dd3c (patch)
treed32e41e41ccb72898997309477e02c3f56f2f405 /user/guile
parentef4fbd05970fd6b09360951d532678445cdb3f67 (diff)
downloadpackages-36df2a269acd2a150d7713f07504213963f0dd3c.tar.gz
packages-36df2a269acd2a150d7713f07504213963f0dd3c.tar.bz2
packages-36df2a269acd2a150d7713f07504213963f0dd3c.tar.xz
packages-36df2a269acd2a150d7713f07504213963f0dd3c.zip
user/guile: pull in, bump to 2.2 series (working fine at 2.2.4)
Diffstat (limited to 'user/guile')
-rw-r--r--user/guile/0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch29
-rw-r--r--user/guile/APKBUILD38
2 files changed, 67 insertions, 0 deletions
diff --git a/user/guile/0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch b/user/guile/0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch
new file mode 100644
index 000000000..cbe194dfd
--- /dev/null
+++ b/user/guile/0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch
@@ -0,0 +1,29 @@
+From be9d97e0eeb2423b86fad7094a462b142f5176f7 Mon Sep 17 00:00:00 2001
+From: Rob Browning <rlb@defaultvalue.org>
+Date: Sun, 18 Mar 2012 13:28:24 -0500
+Subject: Mark "mutex with owner not retained" threads test as unresolved.
+
+As per discussion with upstream, mark this test as unresolved since it
+may produce false negatives, depending on the behavior/timing of the
+garbage collector.
+---
+ test-suite/tests/threads.test | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/test-suite/tests/threads.test b/test-suite/tests/threads.test
+index 8178120..7d180de 100644
+--- a/test-suite/tests/threads.test
++++ b/test-suite/tests/threads.test
+@@ -412,8 +412,10 @@
+
+ (gc) (gc)
+ (let ((m (g)))
+- (and (mutex? m)
+- (eq? (mutex-owner m) (current-thread)))))))
++ (or
++ (and (mutex? m)
++ (eq? (mutex-owner m) (current-thread)))
++ (throw 'unresolved))))))
+
+ ;;
+ ;; mutex lock levels
diff --git a/user/guile/APKBUILD b/user/guile/APKBUILD
new file mode 100644
index 000000000..d670c2353
--- /dev/null
+++ b/user/guile/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer:
+pkgname=guile
+pkgver=2.2.4
+pkgrel=0
+pkgdesc="Portable, embeddable Scheme implementation written in C"
+url="https://www.gnu.org/software/guile/"
+arch="all"
+options="!check !dbg" # Requires actual LC_COLLATE and LC_MONETARY support.
+license="LGPL-3.0+ AND GPL-3.0+"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+makedepends="gmp-dev libtool ncurses-dev texinfo libunistring-dev libffi-dev
+ gc-dev"
+depends=
+depends_dev="guile gc-dev"
+install=
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ 0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-error-on-warning \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/charset.alias
+}
+
+sha512sums="a200b83a02ef23c8256d9bfb14a141bb6dbca01279a0587bfb672060429c49093088e4b765b7ee5c85cd587a1aeed77d9438d300d3e67cdd6cebbb794d88171e guile-2.2.4.tar.gz
+b1c309cc07830ff1741ef88857f8099187b449580e8d57862886abc367ef1accc5a35636d81eee09247f13d3a751cdc8909fdea05368d3d509bd2039ce06d078 0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch"