summaryrefslogtreecommitdiff
path: root/user/hdparm
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-09 05:44:49 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-09 05:44:49 +0000
commit73a0ca55d8be33cce8dde0c35e4273c9bbd6a01e (patch)
treecdf90ca6b5cba988f77e9f1539f6add967a98e27 /user/hdparm
parent43b362a34677898baa14d2c17e184bee43a0a66d (diff)
downloadpackages-73a0ca55d8be33cce8dde0c35e4273c9bbd6a01e.tar.gz
packages-73a0ca55d8be33cce8dde0c35e4273c9bbd6a01e.tar.bz2
packages-73a0ca55d8be33cce8dde0c35e4273c9bbd6a01e.tar.xz
packages-73a0ca55d8be33cce8dde0c35e4273c9bbd6a01e.zip
user/*: Modernise / fix syntax / deps / metadata
Diffstat (limited to 'user/hdparm')
-rw-r--r--user/hdparm/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/hdparm/APKBUILD b/user/hdparm/APKBUILD
index f6e5a8f8e..f1ab5fe96 100644
--- a/user/hdparm/APKBUILD
+++ b/user/hdparm/APKBUILD
@@ -6,11 +6,12 @@ pkgrel=0
pkgdesc="Utility for manipulating IDE device parameters"
url="https://sourceforge.net/projects/hdparm"
arch="all"
+options="!check" # This application has no tests.
license="BSD-2-clause OR GPL-2.0-or-later"
+depends=""
makedepends="linux-headers"
-options="!check" # this application has no tests
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
@@ -18,13 +19,11 @@ prepare() {
}
build() {
- cd "$builddir"
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m755 contrib/idectl "$pkgdir"/sbin
install -D -m755 contrib/ultrabayd "$pkgdir"/sbin