summaryrefslogtreecommitdiff
path: root/user/hexchat
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-24 00:05:30 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-24 00:05:30 -0500
commit9da0d8d70f745811e19e235751e5999c3c80e7a8 (patch)
tree16f4a47459d2fe292df16c72d506afc622a7e1f5 /user/hexchat
parent815bd9899c56b05ae528b9b59410873ee37446ed (diff)
downloadpackages-9da0d8d70f745811e19e235751e5999c3c80e7a8.tar.gz
packages-9da0d8d70f745811e19e235751e5999c3c80e7a8.tar.bz2
packages-9da0d8d70f745811e19e235751e5999c3c80e7a8.tar.xz
packages-9da0d8d70f745811e19e235751e5999c3c80e7a8.zip
user/hexchat: bump to 2.14.1, move to experimental/
We can't build this until a gettext-tiny issue is fixed.[1] [1]: https://github.com/sabotage-linux/gettext-tiny/issues/36
Diffstat (limited to 'user/hexchat')
-rw-r--r--user/hexchat/APKBUILD61
-rw-r--r--user/hexchat/libressl.patch105
-rw-r--r--user/hexchat/pixdata.patch56
3 files changed, 0 insertions, 222 deletions
diff --git a/user/hexchat/APKBUILD b/user/hexchat/APKBUILD
deleted file mode 100644
index 5f43c168d..000000000
--- a/user/hexchat/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=hexchat
-pkgver=2.12.4
-pkgrel=1
-pkgdesc="A popular and easy to use graphical IRC (chat) client"
-url="https://hexchat.github.io"
-arch="all"
-license="GPL2+"
-depends=""
-makedepends="gtk+2.0-dev openssl-dev dbus-glib-dev perl-dev libsexy-dev
- libnotify-dev libproxy-dev bash libtool autoconf automake"
-install=""
-subpackages="$pkgname-doc $pkgname-lang $pkgname-perl:_perl"
-source="https://dl.hexchat.net/hexchat/hexchat-$pkgver-repack.tar.xz
- pixdata.patch
- "
-
-builddir="$srcdir"/hexchat-$pkgver
-prepare() {
- cd "$builddir"
- default_prepare
- autoreconf -vif
-}
-
-build() {
- cd "$builddir"
- LUA=lua5.3 \
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --enable-openssl \
- --enable-dbus \
- --disable-textfe \
- --enable-perl \
- --disable-python \
- --disable-lua
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- # not worth a -dev pkg
- rm -r "$pkgdir"/usr/include
-}
-
-_perl() {
- pkgdesc="Perl plugin for Hexchat"
- depends="$pkgname=$pkgver-r$pkgrel"
- install_if="$pkgname=$pkgver-r$pkgrel perl"
- mkdir -p "$subpkgdir"/usr/lib/hexchat/plugins
- mv "$pkgdir"/usr/lib/hexchat/plugins/perl.so \
- "$subpkgdir"/usr/lib/hexchat/plugins
-}
-
-sha512sums="30d42f5b488abec3fa457254720a39f62619338a5a2c3fe2e5a255aafe1b19817451b01cd260eab90868df1ebf9f663c60b78b6db974ca3c777272327c0b8a25 hexchat-2.12.4-repack.tar.xz
-5cb7ac95e6d53d677d7ec82485636f2c36003ba7fa0c4d4d353095dc6207c51abdc7a2230d43616895fef8ce2c7c2096bec21ac47117d0adbc7416ff3d4ba2c3 pixdata.patch"
diff --git a/user/hexchat/libressl.patch b/user/hexchat/libressl.patch
deleted file mode 100644
index d829dee39..000000000
--- a/user/hexchat/libressl.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-From d583ca7d922e5ac6ff466df2e4411b1303a3a2a3 Mon Sep 17 00:00:00 2001
-From: Florian Stinglmayr <florian@n0la.org>
-Date: Tue, 13 Dec 2016 18:41:43 +0100
-Subject: [PATCH] Use AC_CHECK_FUNCS to find functions not in LibreSSL
-
-LibreSSL might not have all functions of OpenSSL 1.1.0 so use
-AC_CHECK_FUNCS to find them first before using them.
-
-Closes #1899
-Fixes #1898
----
- configure.ac | 2 ++
- src/common/ssl.c | 4 ++--
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 34e6def..1f442c5 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -374,6 +374,8 @@ AS_IF([test "$openssl" != no], [
- openssl=yes
- COMMON_LIBS="$COMMON_LIBS $OPENSSL_LIBS"
- COMMON_CFLAGS="$COMMON_CFLAGS $OPENSSL_CFLAGS"
-+ dnl Test for various functions that are not available in LibreSSL
-+ AC_CHECK_FUNCS([SSL_CTX_get_ssl_method X509_get_signature_nid])
- ], [
- unset openssl_path ac_cv_lib_ssl_SSL_new ac_cv_header_openssl_ssl_h
- AS_IF([test "$openssl" != yes], [
-diff --git a/src/common/ssl.c b/src/common/ssl.c
-index cb58ce2..76fea7b 100644
---- a/src/common/ssl.c
-+++ b/src/common/ssl.c
-@@ -176,7 +176,7 @@ _SSL_get_cert_info (struct cert_info *cert_info, SSL * ssl)
- return 1;
-
- alg = OBJ_obj2nid (algor->algorithm);
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#ifndef HAVE_X509_GET_SIGNATURE_NID
- sign_alg = OBJ_obj2nid (peer_cert->sig_alg->algorithm);
- #else
- sign_alg = X509_get_signature_nid (peer_cert);
-@@ -306,7 +306,7 @@ _SSL_socket (SSL_CTX *ctx, int sd)
-
- SSL_set_fd (ssl, sd);
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#ifndef HAVE_SSL_CTX_GET_SSL_METHOD
- method = ctx->method;
- #else
- method = SSL_CTX_get_ssl_method (ctx);
-From aa7080f8fe63939d7ff4a0d0b1ec60f0c3eb31be Mon Sep 17 00:00:00 2001
-From: Patrick Griffis <tingping@tingping.se>
-Date: Tue, 13 Dec 2016 17:29:26 -0500
-Subject: [PATCH] Fix building fishlim against libressl also
-
-Also part of #1898
----
- configure.ac | 2 +-
- plugins/fishlim/dh1080.c | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 1f442c5..10a1550 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -375,7 +375,7 @@ AS_IF([test "$openssl" != no], [
- COMMON_LIBS="$COMMON_LIBS $OPENSSL_LIBS"
- COMMON_CFLAGS="$COMMON_CFLAGS $OPENSSL_CFLAGS"
- dnl Test for various functions that are not available in LibreSSL
-- AC_CHECK_FUNCS([SSL_CTX_get_ssl_method X509_get_signature_nid])
-+ AC_CHECK_FUNCS([SSL_CTX_get_ssl_method X509_get_signature_nid DH_set0_pqg DH_get0_key DH_set0_key])
- ], [
- unset openssl_path ac_cv_lib_ssl_SSL_new ac_cv_header_openssl_ssl_h
- AS_IF([test "$openssl" != yes], [
-diff --git a/plugins/fishlim/dh1080.c b/plugins/fishlim/dh1080.c
-index ff6e579..3611758 100644
---- a/plugins/fishlim/dh1080.c
-+++ b/plugins/fishlim/dh1080.c
-@@ -74,7 +74,7 @@ dh1080_init (void)
-
- BN_set_word (g, 2);
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#ifndef HAVE_DH_SET0_PQG
- g_dh->p = p;
- g_dh->g = g;
- #else
-@@ -162,7 +162,7 @@ dh1080_generate_key (char **priv_key, char **pub_key)
- return 0;
- }
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#ifndef HAVE_DH_GET0_KEY
- dh_pub_key = dh->pub_key;
- dh_priv_key = dh->priv_key;
- #else
-@@ -213,7 +213,7 @@ dh1080_compute_key (const char *priv_key, const char *pub_key, char **secret_key
-
- priv_key_data = dh1080_decode_b64 (priv_key, &priv_key_len);
- priv_key_num = BN_bin2bn(priv_key_data, priv_key_len, NULL);
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#ifndef HAVE_DH_SET0_KEY
- dh->priv_key = priv_key_num;
- #else
- DH_set0_key (dh, NULL, priv_key_num);
diff --git a/user/hexchat/pixdata.patch b/user/hexchat/pixdata.patch
deleted file mode 100644
index 4e720a848..000000000
--- a/user/hexchat/pixdata.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 4c178782a779f013fafab476506f7d4dae372b8a Mon Sep 17 00:00:00 2001
-From: Patrick Griffis <tingping@tingping.se>
-Date: Sat, 17 Dec 2016 19:55:06 -0500
-Subject: [PATCH] Don't combine compression with pixdata option for icon
- resources
-
-This made minimal difference and is not recommended by upstream.
-It also is affected by a regression in the latest gdk-pixbuf release.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=776105
----
- data/hexchat.gresource.xml | 28 ++++++++++++++--------------
- 1 file changed, 14 insertions(+), 14 deletions(-)
-
-diff --git a/data/hexchat.gresource.xml b/data/hexchat.gresource.xml
-index c125da2..5845da5 100644
---- a/data/hexchat.gresource.xml
-+++ b/data/hexchat.gresource.xml
-@@ -1,23 +1,23 @@
- <?xml version="1.0" encoding="UTF-8"?>
- <gresources>
- <gresource prefix="/icons">
-- <file alias="hexchat.png" preprocess="to-pixdata" compressed="true">icons/hexchat.png</file>
-- <file alias="book.png" preprocess="to-pixdata" compressed="true">icons/book.png</file>
-+ <file alias="hexchat.png" preprocess="to-pixdata">icons/hexchat.png</file>
-+ <file alias="book.png" preprocess="to-pixdata">icons/book.png</file>
-
-- <file alias="ulist_voice.png" preprocess="to-pixdata" compressed="true">icons/ulist_voice.png</file>
-- <file alias="ulist_halfop.png" preprocess="to-pixdata" compressed="true">icons/ulist_halfop.png</file>
-- <file alias="ulist_op.png" preprocess="to-pixdata" compressed="true">icons/ulist_op.png</file>
-- <file alias="ulist_owner.png" preprocess="to-pixdata" compressed="true">icons/ulist_owner.png</file>
-- <file alias="ulist_founder.png" preprocess="to-pixdata" compressed="true">icons/ulist_founder.png</file>
-- <file alias="ulist_netop.png" preprocess="to-pixdata" compressed="true">icons/ulist_netop.png</file>
-+ <file alias="ulist_voice.png" preprocess="to-pixdata">icons/ulist_voice.png</file>
-+ <file alias="ulist_halfop.png" preprocess="to-pixdata">icons/ulist_halfop.png</file>
-+ <file alias="ulist_op.png" preprocess="to-pixdata">icons/ulist_op.png</file>
-+ <file alias="ulist_owner.png" preprocess="to-pixdata">icons/ulist_owner.png</file>
-+ <file alias="ulist_founder.png" preprocess="to-pixdata">icons/ulist_founder.png</file>
-+ <file alias="ulist_netop.png" preprocess="to-pixdata">icons/ulist_netop.png</file>
-
-- <file alias="tray_fileoffer.png" preprocess="to-pixdata" compressed="true">icons/tray_fileoffer.png</file>
-- <file alias="tray_highlight.png" preprocess="to-pixdata" compressed="true">icons/tray_highlight.png</file>
-- <file alias="tray_message.png" preprocess="to-pixdata" compressed="true">icons/tray_message.png</file>
-+ <file alias="tray_fileoffer.png" preprocess="to-pixdata">icons/tray_fileoffer.png</file>
-+ <file alias="tray_highlight.png" preprocess="to-pixdata">icons/tray_highlight.png</file>
-+ <file alias="tray_message.png" preprocess="to-pixdata">icons/tray_message.png</file>
-
- <file alias="tree_channel.png" preprocess="to-pixdata">icons/tree_channel.png</file>
-- <file alias="tree_dialog.png" preprocess="to-pixdata" compressed="true">icons/tree_dialog.png</file>
-- <file alias="tree_server.png" preprocess="to-pixdata" compressed="true">icons/tree_server.png</file>
-- <file alias="tree_util.png" preprocess="to-pixdata" compressed="true">icons/tree_util.png</file>
-+ <file alias="tree_dialog.png" preprocess="to-pixdata">icons/tree_dialog.png</file>
-+ <file alias="tree_server.png" preprocess="to-pixdata">icons/tree_server.png</file>
-+ <file alias="tree_util.png" preprocess="to-pixdata">icons/tree_util.png</file>
- </gresource>
- </gresources>