summaryrefslogtreecommitdiff
path: root/user/hwloc/APKBUILD
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2019-10-13 05:14:51 +0000
committerDan Theisen <djt@hxx.in>2020-04-23 06:24:33 +0000
commitba8de618905acb1f569cdcc76e46a7f7dc885c16 (patch)
tree7b0b1a8161e1e1b8963f3fec9e8175d16b2d557f /user/hwloc/APKBUILD
parentba6c071c6d64bfb3682333c2a5bafc2db41236dd (diff)
downloadpackages-ba8de618905acb1f569cdcc76e46a7f7dc885c16.tar.gz
packages-ba8de618905acb1f569cdcc76e46a7f7dc885c16.tar.bz2
packages-ba8de618905acb1f569cdcc76e46a7f7dc885c16.tar.xz
packages-ba8de618905acb1f569cdcc76e46a7f7dc885c16.zip
user/hwloc: new package
Diffstat (limited to 'user/hwloc/APKBUILD')
-rw-r--r--user/hwloc/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/hwloc/APKBUILD b/user/hwloc/APKBUILD
new file mode 100644
index 000000000..29f389fe2
--- /dev/null
+++ b/user/hwloc/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Dan Theisen <djt@hxx.in
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=hwloc
+pkgver=1.11.13
+_pkgver=${pkgver%.*}
+pkgrel=0
+pkgdesc="Hardware Locality library for portable system topology information"
+url="https://www.open-mpi.org/projects/hwloc/"
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.open-mpi.org/release/hwloc/v${_pkgver}/${pkgname}-${pkgver}.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="dd38bcc9a5df2dcfd3bbd828ab13fdb1c1d21747a0b62e6c87df95d2835c0472590344ff5bda4f6c28e597eaba1ea11c0bc96907ad45f1215f51f95ac9f58138 hwloc-1.11.13.tar.bz2"