summaryrefslogtreecommitdiff
path: root/user/iso-codes
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-22 23:10:43 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-22 23:10:43 -0500
commit2497ff18e90b6e0aaffb3ab57b106b3f6a422692 (patch)
tree60a0876c57b9d82f578ae9c9b190c90138af3027 /user/iso-codes
parente9d285285011bf6c9a278a51bb6758fd7be4cf19 (diff)
downloadpackages-2497ff18e90b6e0aaffb3ab57b106b3f6a422692.tar.gz
packages-2497ff18e90b6e0aaffb3ab57b106b3f6a422692.tar.bz2
packages-2497ff18e90b6e0aaffb3ab57b106b3f6a422692.tar.xz
packages-2497ff18e90b6e0aaffb3ab57b106b3f6a422692.zip
user/iso-codes: pull in, take, bump to 3.79, fix metadata
Diffstat (limited to 'user/iso-codes')
-rw-r--r--user/iso-codes/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/iso-codes/APKBUILD b/user/iso-codes/APKBUILD
new file mode 100644
index 000000000..64ceee132
--- /dev/null
+++ b/user/iso-codes/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=iso-codes
+pkgver=3.79
+pkgrel=0
+pkgdesc="Lists of country, language, and currency names"
+url=" "
+arch="noarch"
+license="LGPL-2.1+"
+depends=""
+makedepends="python3"
+subpackages="$pkgname-lang $pkgname-dev"
+source="http://anduin.linuxfromscratch.org/BLFS/$pkgname/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" pkgconfigdir=/usr/lib/pkgconfig install
+}
+
+sha512sums="286d4f328142cdc7ace409d2aaa811e3732df49d78b1875ce71f76f1bb683ce0c4d3f9d2bba752bf6cd25ee8f4c53bdc84568e2eaf85f49650452df19800b345 iso-codes-3.79.tar.xz"