summaryrefslogtreecommitdiff
path: root/user/kcalcore/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-11 22:46:18 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-11 22:46:18 -0500
commit17503d435ad575336d48ade76a88e76cc51b8322 (patch)
tree85ddc30457acf09f94895ef5d60ba7feb75bb6c8 /user/kcalcore/APKBUILD
parente80841350bb8ae1e7be331da6ce0bb58993b6042 (diff)
downloadpackages-17503d435ad575336d48ade76a88e76cc51b8322.tar.gz
packages-17503d435ad575336d48ade76a88e76cc51b8322.tar.bz2
packages-17503d435ad575336d48ade76a88e76cc51b8322.tar.xz
packages-17503d435ad575336d48ade76a88e76cc51b8322.zip
user/kcalcore: new package
Diffstat (limited to 'user/kcalcore/APKBUILD')
-rw-r--r--user/kcalcore/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/user/kcalcore/APKBUILD b/user/kcalcore/APKBUILD
new file mode 100644
index 000000000..3e7b2700d
--- /dev/null
+++ b/user/kcalcore/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kcalcore
+pkgver=17.08.1
+pkgrel=0
+pkgdesc="Library for managing a calendar of events"
+url="https://www.kde.org/"
+arch="all"
+license="LGPL-2.0"
+depends=""
+depends_dev="qt5-qtbase-dev kconfig-dev kdelibs4support-dev libical-dev"
+makedepends="$depends_dev cmake extra-cmake-modules bison"
+checkdepends="tzdata"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.kde.org/stable/applications/$pkgver/src/kcalcore-$pkgver.tar.xz
+ posix-header.patch"
+builddir="$srcdir/kcalcore-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E RecursOn-RFC2445_RRULETest39.ics
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e4602de6a2482b5c6f54dc5247638e0d440813dd964582b42e4c3e2d9865370ad82e24539e01db3c70f24649d5c4116407aabb2b1fab5bb954d95cf8b867c834 kcalcore-17.08.1.tar.xz
+d911c2a03b1db1f9f3b19e7087ae5cbee59ced24ded3b43f2d3286651d13e5f531d171cf7dc6c26906116d4b51a79f2801828956fa1f4e7094fa2f53fe2b888f posix-header.patch"