summaryrefslogtreecommitdiff
path: root/user/kdiamond
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-31 18:51:55 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-31 18:51:55 +0000
commit26f7c605a6e0d82dd20111c6da9a6f3270e9b0ce (patch)
treecf354b8455ac23203e1af2f92855d1dfd75fab30 /user/kdiamond
parented5c897462a687dc046b4cdcda69f8d108e1b28c (diff)
downloadpackages-26f7c605a6e0d82dd20111c6da9a6f3270e9b0ce.tar.gz
packages-26f7c605a6e0d82dd20111c6da9a6f3270e9b0ce.tar.bz2
packages-26f7c605a6e0d82dd20111c6da9a6f3270e9b0ce.tar.xz
packages-26f7c605a6e0d82dd20111c6da9a6f3270e9b0ce.zip
user/[KDE Games]: Bump to 19.12.0
Excludes user/kpat, which requires a bunch of Perl packages.
Diffstat (limited to 'user/kdiamond')
-rw-r--r--user/kdiamond/APKBUILD11
-rw-r--r--user/kdiamond/ridiculous-qt.patch11
2 files changed, 4 insertions, 18 deletions
diff --git a/user/kdiamond/APKBUILD b/user/kdiamond/APKBUILD
index 9e938ea76..883ab60c2 100644
--- a/user/kdiamond/APKBUILD
+++ b/user/kdiamond/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kdiamond
-pkgver=19.08.2
+pkgver=19.12.0
pkgrel=0
pkgdesc="Three-in-a-row game"
url="https://games.kde.org/game.php?game=kdiamond"
@@ -13,9 +13,7 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev
ki18n-dev kconfigwidgets-dev kxmlgui-dev knotifications-dev
knotifyconfig-dev libkdegames-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/kdiamond-$pkgver.tar.xz
- ridiculous-qt.patch
- "
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdiamond-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -28,7 +26,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
@@ -40,5 +38,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3626805431c7acf3a00ed0d3a8c1d3e6f0cf7fe5cd4712235e916d06697a61e1433e97deea5a6eb96411ce08df660cbf008a22fe98c2e0489c9f28c2f9755f76 kdiamond-19.08.2.tar.xz
-b29c091b45376fa83192b0cd2876de7323648caa597e610c3d13d883ee0df269e9aa9e5367469e0d787a147ade590e6cd1b2c04162da0e8405220067d4e44129 ridiculous-qt.patch"
+sha512sums="dba10a80839daa6e05b2531e10724996895e23c167d8865b752db9188072fa7b36ef6fb56fd774485bc4a2113eae5e7c5bda0be66f41df47712378ccbd507f15 kdiamond-19.12.0.tar.xz"
diff --git a/user/kdiamond/ridiculous-qt.patch b/user/kdiamond/ridiculous-qt.patch
deleted file mode 100644
index 8e042f59a..000000000
--- a/user/kdiamond/ridiculous-qt.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- kdiamond-19.08.0/CMakeLists.txt.old 2019-08-09 00:27:58.000000000 +0000
-+++ kdiamond-19.08.0/CMakeLists.txt 2019-08-15 12:36:41.785854337 +0000
-@@ -1,7 +1,7 @@
- cmake_minimum_required (VERSION 3.5 FATAL_ERROR)
- project(kdiamond)
-
--set (QT_MIN_VERSION "5.10.0")
-+set (QT_MIN_VERSION "5.9.0")
- set (KF5_MIN_VERSION "5.46.0")
-
- find_package(ECM ${KF5_MIN_VERSION} REQUIRED CONFIG)